summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cram/cram-0.7-r2.ebuild')
-rw-r--r--dev-util/cram/cram-0.7-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/cram/cram-0.7-r2.ebuild b/dev-util/cram/cram-0.7-r2.ebuild
new file mode 100644
index 000000000000..56867074f7fe
--- /dev/null
+++ b/dev-util/cram/cram-0.7-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Functional testing framework for command line applications"
+HOMEPAGE="https://bitheap.org/cram/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+}