summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/drone-cli/drone-cli-1.0.4.ebuild')
-rw-r--r--dev-util/drone-cli/drone-cli-1.0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/drone-cli/drone-cli-1.0.4.ebuild b/dev-util/drone-cli/drone-cli-1.0.4.ebuild
new file mode 100644
index 000000000000..76b00a393dc2
--- /dev/null
+++ b/dev-util/drone-cli/drone-cli-1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/drone/drone-cli"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Command-line interface for Drone"
+HOMEPAGE="https://github.com/drone/drone-cli"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="!!<dev-util/drone-0.7"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install -ldflags "-X main.version=${PV}" ${EGO_PN}/drone || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/drone
+ dodoc src/${EGO_PN}/README.md
+}