summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild')
-rw-r--r--dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild b/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
index 2c9be9381e6e..3ec785445ba2 100644
--- a/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
+++ b/dev-util/editorconfig-geany/editorconfig-geany-0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,6 +29,15 @@ src_prepare() {
-e "s|^\\(LDFLAGS =.*\\)|\\1 ${LDFLAGS}|" \
-e "s|\`pkg-config[^\`]*\`||" \
-i Makefile || die
+
+ # https://github.com/editorconfig/editorconfig-geany/pull/15
+ cat << "EOF" > "${T}/GeanyFunctions.patch" || die
+--- a/editorconfig-geany.c
++++ b/editorconfig-geany.c
+@@ -33 +32,0 @@
+-GeanyFunctions* geany_functions;
+EOF
+ eapply -p1 "${T}/GeanyFunctions.patch"
}
src_install() {