summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/Manifest3
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch55
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-1.38-libgit2-1.4.patch139
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-1.38-webkit2gtk-4.1.patch20
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-2.0-gcc14.patch11
-rw-r--r--dev-util/geany-plugins/files/geany-plugins-2.0-webkit2gtk-4.1.patch33
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.38-r410.ebuild (renamed from dev-util/geany-plugins/geany-plugins-1.36-r2.ebuild)72
-rw-r--r--dev-util/geany-plugins/geany-plugins-2.0-r1.ebuild127
-rw-r--r--dev-util/geany-plugins/geany-plugins-2.0.ebuild124
-rw-r--r--dev-util/geany-plugins/metadata.xml11
10 files changed, 502 insertions, 93 deletions
diff --git a/dev-util/geany-plugins/Manifest b/dev-util/geany-plugins/Manifest
index 5343c304284a..25ccad7bbbff 100644
--- a/dev-util/geany-plugins/Manifest
+++ b/dev-util/geany-plugins/Manifest
@@ -1 +1,2 @@
-DIST geany-plugins-1.36.tar.gz 4693634 BLAKE2B a7c319a77cb92a55a0a53063ab75d9375f7d2a0e419eb3e0acd063b8fda4b4d9798c103ce53b80090c73bd86804c58f815aaf8d0eecc0d7fbf7ad1c8470cb9b5 SHA512 b3e58b42432d17c27289fa20d10b833a2d7f5d8c72b51abe5b1ebdabcb952b18e0984b15ef6ac9753102d839f3174f28798269e1e94bf032bdaa189e98d72b2d
+DIST geany-plugins-1.38.tar.gz 4783970 BLAKE2B 386a05d7136183799059ef6d73b28a0d67d738939b0dc57649ac68f1049104568fe7c8453ebf2144277f60ee0834564b19bf4e756168864f1551962ba2411c14 SHA512 82d04331e23c5d81765b11e081a960a7a17172184cabe94efd2ddb37ac94668349b036e6083f77c867ac650fa7b251ba3970ae26b562b4568d6e313652763339
+DIST geany-plugins-2.0.tar.bz2 3181264 BLAKE2B 6175f91a3a7effa081393e9397336e0f5f59846fdadd0e31584f237c14863016cc4ab1b17745e1e2804ad88161dc7e43aef97a2332a5c18a7f1baf10d2ea42ba SHA512 48d575459e5c9f905b8809796ea89a05f6e082a1bb1d29c9f44dd5de607a64ad65a27d18348312702d25cfbb80ea0348b9e806f8c0fe649ea558b5b4ccd84818
diff --git a/dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch b/dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch
deleted file mode 100644
index 25e5ac4ea28e..000000000000
--- a/dev-util/geany-plugins/files/geany-plugins-1.36-libgit2-0.99.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 9497d829e1b207eb83575dc6f617feecfb89bc16 Mon Sep 17 00:00:00 2001
-From: Dominik Schmidt <dominik@schm1dt.ch>
-Date: Sun, 23 Feb 2020 19:15:30 +0100
-Subject: [PATCH] Make libgit2 version preprocessor conditionals compatible
- with libgit2-0.99
-
-LIBGIT2_SOVERSION is defined as string literal, e.g. "0.99",
-from libgit2-0.99 and beyond. Arithmetic checks against this
-variable whill hence fail. This patch switches the checks to
-compare against the LIBGIT2_VER_* family, which should be more stable.
----
- git-changebar/src/gcb-plugin.c | 6 +++---
- workbench/src/plugin_main.c | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/git-changebar/src/gcb-plugin.c b/git-changebar/src/gcb-plugin.c
-index b7083199..a911815f 100644
---- a/git-changebar/src/gcb-plugin.c
-+++ b/git-changebar/src/gcb-plugin.c
-@@ -32,11 +32,11 @@
- #include <geany.h>
- #include <document.h>
-
--#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22
-+#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22) )
- # define git_libgit2_init git_threads_init
- # define git_libgit2_shutdown git_threads_shutdown
- #endif
--#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 23
-+#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 23) )
- /* 0.23 added @p binary_cb */
- # define git_diff_buffers(old_buffer, old_len, old_as_path, \
- new_buffer, new_len, new_as_path, options, \
-@@ -45,7 +45,7 @@
- new_buffer, new_len, new_as_path, options, \
- file_cb, hunk_cb, line_cb, payload)
- #endif
--#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 28
-+#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 28) )
- # define git_buf_dispose git_buf_free
- # define git_error_last giterr_last
- #endif
-diff --git a/workbench/src/plugin_main.c b/workbench/src/plugin_main.c
-index 6fa6fc84..25ecdf6d 100644
---- a/workbench/src/plugin_main.c
-+++ b/workbench/src/plugin_main.c
-@@ -36,7 +36,7 @@
- #include "tm_control.h"
-
-
--#if ! defined (LIBGIT2_SOVERSION) || LIBGIT2_SOVERSION < 22
-+#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22))
- # define git_libgit2_init git_threads_init
- # define git_libgit2_shutdown git_threads_shutdown
- #endif
diff --git a/dev-util/geany-plugins/files/geany-plugins-1.38-libgit2-1.4.patch b/dev-util/geany-plugins/files/geany-plugins-1.38-libgit2-1.4.patch
new file mode 100644
index 000000000000..87034471d09e
--- /dev/null
+++ b/dev-util/geany-plugins/files/geany-plugins-1.38-libgit2-1.4.patch
@@ -0,0 +1,139 @@
+# https://github.com/geany/geany-plugins/commit/668f5d07eef16e227402eab09141c738b315d94b
+# https://github.com/geany/geany-plugins/commit/5d9f1bc6d010e6b4c6a21af8a39b90922f89a82c
+--- a/git-changebar/src/gcb-plugin.c
++++ b/git-changebar/src/gcb-plugin.c
+@@ -32,11 +32,19 @@
+ #include <geany.h>
+ #include <document.h>
+
+-#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 22) )
++#ifdef LIBGIT2_VER_MINOR
++# define CHECK_LIBGIT2_VERSION(MAJOR, MINOR) \
++ ((LIBGIT2_VER_MAJOR == (MAJOR) && LIBGIT2_VER_MINOR >= (MINOR)) || \
++ LIBGIT2_VER_MAJOR > (MAJOR))
++#else /* ! defined(LIBGIT2_VER_MINOR) */
++# define CHECK_LIBGIT2_VERSION(MAJOR, MINOR) 0
++#endif
++
++#if ! CHECK_LIBGIT2_VERSION(0, 22)
+ # define git_libgit2_init git_threads_init
+ # define git_libgit2_shutdown git_threads_shutdown
+ #endif
+-#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 23) )
++#if ! CHECK_LIBGIT2_VERSION(0, 23)
+ /* 0.23 added @p binary_cb */
+ # define git_diff_buffers(old_buffer, old_len, old_as_path, \
+ new_buffer, new_len, new_as_path, options, \
+@@ -45,7 +53,7 @@
+ new_buffer, new_len, new_as_path, options, \
+ file_cb, hunk_cb, line_cb, payload)
+ #endif
+-#if ! defined (LIBGIT2_VER_MINOR) || ( (LIBGIT2_VER_MAJOR == 0) && (LIBGIT2_VER_MINOR < 28) )
++#if ! CHECK_LIBGIT2_VERSION(0, 28)
+ # define git_buf_dispose git_buf_free
+ # define git_error_last giterr_last
+ #endif
+@@ -211,30 +219,19 @@ static const struct {
+ };
+
+
+-/* workaround https://github.com/libgit2/libgit2/pull/3187 */
+-static int
+-gcb_git_buf_grow (git_buf *buf,
+- size_t target_size)
+-{
+- if (buf->asize == 0) {
+- if (target_size == 0) {
+- target_size = buf->size;
+- }
+- if ((target_size & 7) == 0) {
+- target_size++;
+- }
+- }
+- return git_buf_grow (buf, target_size);
+-}
+-#define git_buf_grow gcb_git_buf_grow
+-
+ static void
+ buf_zero (git_buf *buf)
+ {
+ if (buf) {
+ buf->ptr = NULL;
+ buf->size = 0;
++#if ! CHECK_LIBGIT2_VERSION(1, 4)
+ buf->asize = 0;
++#else
++ /* we don't really need this field, but the documentation states that all
++ * fields should be set to 0, so fill it as well */
++ buf->reserved = 0;
++#endif
+ }
+ }
+
+@@ -248,6 +245,52 @@ clear_cached_blob_contents (void)
+ G_blob_contents_tag = 0;
+ }
+
++/* similar to old git_blob_filtered_content() but makes sure the caller owns
++ * the data in the output buffer -- and uses a boolean return */
++static gboolean
++get_blob_contents (git_buf *out,
++ git_blob *blob,
++ const char *as_path,
++ int check_for_binary_data)
++{
++/* libgit2 1.4 changed buffer API quite a bit */
++#if ! CHECK_LIBGIT2_VERSION(1, 4)
++ gboolean success = TRUE;
++
++ if (git_blob_filtered_content (out, blob, as_path,
++ check_for_binary_data) != 0)
++ return FALSE;
++
++ /* Workaround for https://github.com/libgit2/libgit2/pull/3187
++ * We want to own the buffer, which git_buf_grow(buf, 0) was supposed to do,
++ * but there is a corner case where it doesn't do what it should and
++ * truncates the buffer contents, so we fix this manually. */
++ if (out->asize == 0) {
++ size_t target_size = out->size;
++ if ((target_size & 7) == 0) {
++ target_size++;
++ }
++ success = (git_buf_grow (out, target_size) == 0);
++ }
++
++ return success;
++#else /* libgit2 >= 1.4 */
++ /* Here we can assume we will always get a buffer we own (at least as of
++ * 2022-06-05 it is the case), so there's no need for a pendent to the
++ * previous git_buf_grow() shenanigans.
++ * This code path does the same as the older git_blob_filtered_content()
++ * but with non-deprecated API */
++ git_blob_filter_options opts = GIT_BLOB_FILTER_OPTIONS_INIT;
++
++ if (check_for_binary_data)
++ opts.flags |= GIT_BLOB_FILTER_CHECK_FOR_BINARY;
++ else
++ opts.flags &= ~GIT_BLOB_FILTER_CHECK_FOR_BINARY;
++
++ return git_blob_filter(out, blob, as_path, &opts) == 0;
++#endif
++}
++
+ /* get the file blob for @relpath at HEAD */
+ static gboolean
+ repo_get_file_blob_contents (git_repository *repo,
+@@ -271,11 +314,8 @@ repo_get_file_blob_contents (git_repository *repo,
+ git_blob *blob;
+
+ if (git_blob_lookup (&blob, repo, git_tree_entry_id (entry)) == 0) {
+- if (git_blob_filtered_content (contents, blob, relpath,
+- check_for_binary_data) == 0 &&
+- git_buf_grow (contents, 0) == 0) {
+- success = TRUE;
+- }
++ success = get_blob_contents (contents, blob, relpath,
++ check_for_binary_data);
+ git_blob_free (blob);
+ }
+ git_tree_entry_free (entry);
diff --git a/dev-util/geany-plugins/files/geany-plugins-1.38-webkit2gtk-4.1.patch b/dev-util/geany-plugins/files/geany-plugins-1.38-webkit2gtk-4.1.patch
new file mode 100644
index 000000000000..ad543af6587f
--- /dev/null
+++ b/dev-util/geany-plugins/files/geany-plugins-1.38-webkit2gtk-4.1.patch
@@ -0,0 +1,20 @@
+diff --git a/build/markdown.m4 b/build/markdown.m4
+index 6c1f53a6..39bea2a6 100644
+--- a/build/markdown.m4
++++ b/build/markdown.m4
+@@ -49,13 +49,13 @@ AC_DEFUN([GP_CHECK_MARKDOWN],
+ GTK_VERSION=2.16
+ WEBKIT_VERSION=1.1.13
+
+- GP_CHECK_GTK3([webkit_package=webkit2gtk-4.0],
++ GP_CHECK_GTK3([webkit_package=webkit2gtk-4.1],
+ [webkit_package=webkit-1.0])
+ GP_CHECK_PLUGIN_DEPS([markdown], [MARKDOWN],
+ [$GP_GTK_PACKAGE >= ${GTK_VERSION}
+ $webkit_package >= ${WEBKIT_VERSION}
+ gthread-2.0])
+- AM_CONDITIONAL([MARKDOWN_WEBKIT2], [test "$webkit_package" = webkit2gtk-4.0])
++ AM_CONDITIONAL([MARKDOWN_WEBKIT2], [test "$webkit_package" = webkit2gtk-4.1])
+
+ GP_COMMIT_PLUGIN_STATUS([Markdown])
+
diff --git a/dev-util/geany-plugins/files/geany-plugins-2.0-gcc14.patch b/dev-util/geany-plugins/files/geany-plugins-2.0-gcc14.patch
new file mode 100644
index 000000000000..40978cdab9fb
--- /dev/null
+++ b/dev-util/geany-plugins/files/geany-plugins-2.0-gcc14.patch
@@ -0,0 +1,11 @@
+--- a/projectorganizer/src/prjorg-sidebar.c
++++ b/projectorganizer/src/prjorg-sidebar.c
+@@ -1562,7 +1562,7 @@ gchar **prjorg_sidebar_get_expanded_paths(void)
+ (GtkTreeViewMappingFunc)on_map_expanded, expanded_paths);
+ g_ptr_array_add(expanded_paths, NULL);
+
+- return g_ptr_array_free(expanded_paths, FALSE);
++ return (gchar **) g_ptr_array_free(expanded_paths, FALSE);
+ }
+
+
diff --git a/dev-util/geany-plugins/files/geany-plugins-2.0-webkit2gtk-4.1.patch b/dev-util/geany-plugins/files/geany-plugins-2.0-webkit2gtk-4.1.patch
new file mode 100644
index 000000000000..91015aa1a619
--- /dev/null
+++ b/dev-util/geany-plugins/files/geany-plugins-2.0-webkit2gtk-4.1.patch
@@ -0,0 +1,33 @@
+diff --git a/build/markdown.m4 b/build/markdown.m4
+index 6c1f53a6..39bea2a6 100644
+--- a/build/markdown.m4
++++ b/build/markdown.m4
+@@ -49,13 +49,13 @@ AC_DEFUN([GP_CHECK_MARKDOWN],
+ GTK_VERSION=2.16
+ WEBKIT_VERSION=1.1.13
+
+- GP_CHECK_GTK3([webkit_package=webkit2gtk-4.0],
++ GP_CHECK_GTK3([webkit_package=webkit2gtk-4.1],
+ [webkit_package=webkit-1.0])
+ GP_CHECK_PLUGIN_DEPS([markdown], [MARKDOWN],
+ [$GP_GTK_PACKAGE >= ${GTK_VERSION}
+ $webkit_package >= ${WEBKIT_VERSION}
+ gthread-2.0])
+- AM_CONDITIONAL([MARKDOWN_WEBKIT2], [test "$webkit_package" = webkit2gtk-4.0])
++ AM_CONDITIONAL([MARKDOWN_WEBKIT2], [test "$webkit_package" = webkit2gtk-4.1])
+
+ GP_COMMIT_PLUGIN_STATUS([Markdown])
+
+diff --git a/build/webhelper.m4 b/build/webhelper.m4
+index eacef95c..2325a65f 100644
+--- a/build/webhelper.m4
++++ b/build/webhelper.m4
+@@ -25,7 +25,7 @@ AC_DEFUN([GP_CHECK_WEBHELPER],
+ glib-2.0 >= ${GLIB_VERSION}
+ gio-2.0 >= ${GIO_VERSION}
+ gdk-pixbuf-2.0 >= ${GDK_PIXBUF_VERSION}
+- webkit2gtk-4.0 >= ${WEBKIT_VERSION}
++ webkit2gtk-4.1 >= ${WEBKIT_VERSION}
+ gthread-2.0])
+
+
diff --git a/dev-util/geany-plugins/geany-plugins-1.36-r2.ebuild b/dev-util/geany-plugins/geany-plugins-1.38-r410.ebuild
index 854fb5782672..72532b531671 100644
--- a/dev-util/geany-plugins/geany-plugins-1.36-r2.ebuild
+++ b/dev-util/geany-plugins/geany-plugins-1.38-r410.ebuild
@@ -1,7 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+LUA_REQ_USE="deprecated"
+
+inherit autotools flag-o-matic lua-single
DESCRIPTION="A collection of different plugins for Geany"
HOMEPAGE="https://plugins.geany.org"
@@ -9,51 +14,56 @@ SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 ~sparc x86"
+KEYWORDS="amd64 arm ppc ppc64 ~riscv ~sparc x86"
-IUSE="+gtk3 ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope soup workbench"
-REQUIRED_USE="!gtk3? ( !markdown )"
+IUSE="ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope workbench"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
DEPEND="
dev-libs/glib:2
- >=dev-util/geany-1.35[gtk3=]
- gtk3? ( x11-libs/gtk+:3 )
- !gtk3? ( x11-libs/gtk+:2 )
+ >=dev-util/geany-1.37[-gtk2(-)]
+ x11-libs/gtk+:3
ctags? ( dev-util/ctags )
- debugger? (
- gtk3? ( x11-libs/vte:2.91 )
- !gtk3? ( x11-libs/vte:0 )
- )
+ debugger? ( x11-libs/vte:2.91 )
enchant? ( app-text/enchant:= )
git? ( dev-libs/libgit2:= )
- gpg? ( app-crypt/gpgme:1= )
- gtkspell? (
- gtk3? ( app-text/gtkspell:3= )
- !gtk3? ( app-text/gtkspell:2 )
- )
- lua? ( dev-lang/lua:0= )
+ gpg? ( app-crypt/gpgme:= )
+ gtkspell? ( app-text/gtkspell:3= )
+ lua? ( ${LUA_DEPS} )
markdown? (
- app-text/discount
- net-libs/webkit-gtk:4
+ app-text/discount:=
+ net-libs/webkit-gtk:4.1
)
pretty-printer? ( dev-libs/libxml2:2 )
- scope? (
- gtk3? ( x11-libs/vte:2.91 )
- !gtk3? ( x11-libs/vte:0 )
- )
- soup? ( net-libs/libsoup:2.4 )
+ scope? ( x11-libs/vte:2.91 )
workbench? ( dev-libs/libgit2:= )
"
RDEPEND="${DEPEND}
- scope? ( sys-devel/gdb )
+ scope? ( dev-debug/gdb )
"
BDEPEND="virtual/pkgconfig
nls? ( sys-devel/gettext )
"
-PATCHES=( "${FILESDIR}"/${P}-libgit2-0.99.patch )
+PATCHES=(
+ "${FILESDIR}/${P}-libgit2-1.4.patch"
+ "${FILESDIR}/${P}-webkit2gtk-4.1.patch"
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#878529)
+ use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
+
local myeconfargs=(
--disable-cppcheck
--disable-extra-c-warnings
@@ -66,6 +76,7 @@ src_configure() {
--enable-codenav
--enable-commander
--enable-defineformat
+ --enable-geanydoc
--enable-geanyextrasel
--enable-geanyinsertnum
--enable-geanymacro
@@ -89,20 +100,19 @@ src_configure() {
--enable-xmlsnippets
$(use_enable debugger)
$(use_enable ctags geanyctags)
- $(use_enable !gtk3 geanydoc)
$(use_enable lua geanylua)
$(use_enable gpg geanypg)
- $(use_enable soup geniuspaste)
$(use_enable git gitchangebar)
$(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
$(use_enable pretty-printer)
$(use_enable scope)
$(use_enable enchant spellcheck)
- # Having updatechecker… when you’re using a package manager?
- $(use_enable soup updatechecker)
$(use_enable workbench)
# GeanyGenDoc requires ctpl which isn’t yet in portage
--disable-geanygendoc
+ # Require libsoup-2.4 which conflicts with webkit2gtk-4.1
+ --disable-geniuspaste
+ --disable-updatechecker
# Require obsolete and vulnerable webkit-gtk versions
--disable-devhelp
--disable-webhelper
diff --git a/dev-util/geany-plugins/geany-plugins-2.0-r1.ebuild b/dev-util/geany-plugins/geany-plugins-2.0-r1.ebuild
new file mode 100644
index 000000000000..0c974b7a9e80
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-2.0-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+
+inherit autotools lua-single
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 ~riscv ~sparc x86"
+
+IUSE="ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope webhelper workbench"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-util/geany-2.0
+ x11-libs/gtk+:3
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:2.91 )
+ enchant? ( app-text/enchant:= )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:= )
+ gtkspell? ( app-text/gtkspell:3= )
+ lua? ( ${LUA_DEPS} )
+ markdown? (
+ app-text/discount:=
+ net-libs/webkit-gtk:4.1
+ )
+ pretty-printer? ( dev-libs/libxml2:2 )
+ scope? ( x11-libs/vte:2.91 )
+ webhelper? ( net-libs/webkit-gtk:4.1 )
+ workbench? ( dev-libs/libgit2:= )
+"
+RDEPEND="${DEPEND}
+ scope? ( dev-debug/gdb )
+"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc14.patch"
+ "${FILESDIR}/${P}-webkit2gtk-4.1.patch"
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable nls)
+ --enable-utilslib
+ # Plugins
+ --enable-addons
+ --enable-autoclose
+ --enable-automark
+ --enable-codenav
+ --enable-commander
+ --enable-defineformat
+ --enable-geanydoc
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanymacro
+ --enable-geanyminiscript
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc $(use_enable gtkspell)
+ --enable-keyrecord
+ --enable-latex
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-overview
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-vimode
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable ctags geanyctags)
+ $(use_enable lua geanylua)
+ $(use_enable gpg geanypg)
+ $(use_enable git gitchangebar)
+ $(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
+ $(use_enable pretty-printer)
+ $(use_enable scope)
+ $(use_enable enchant spellcheck)
+ $(use_enable webhelper)
+ $(use_enable workbench)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # Require libsoup-2.4 which conflicts with webkit2gtk-4.1
+ --disable-geniuspaste
+ --disable-updatechecker
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -z "${LINGUAS-x}" ]]; then
+ rm -r "${ED}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/geany-plugins-2.0.ebuild b/dev-util/geany-plugins/geany-plugins-2.0.ebuild
new file mode 100644
index 000000000000..5628c21b1083
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-2.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-1 )
+
+inherit autotools lua-single
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope webhelper workbench"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-util/geany-2.0
+ x11-libs/gtk+:3
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:2.91 )
+ enchant? ( app-text/enchant:= )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:= )
+ gtkspell? ( app-text/gtkspell:3= )
+ lua? ( ${LUA_DEPS} )
+ markdown? (
+ app-text/discount:=
+ net-libs/webkit-gtk:4.1
+ )
+ pretty-printer? ( dev-libs/libxml2:2 )
+ scope? ( x11-libs/vte:2.91 )
+ webhelper? ( net-libs/webkit-gtk:4.1 )
+ workbench? ( dev-libs/libgit2:= )
+"
+RDEPEND="${DEPEND}
+ scope? ( dev-debug/gdb )
+"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=( "${FILESDIR}/${P}-webkit2gtk-4.1.patch" )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable nls)
+ --enable-utilslib
+ # Plugins
+ --enable-addons
+ --enable-autoclose
+ --enable-automark
+ --enable-codenav
+ --enable-commander
+ --enable-defineformat
+ --enable-geanydoc
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanymacro
+ --enable-geanyminiscript
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc $(use_enable gtkspell)
+ --enable-keyrecord
+ --enable-latex
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-overview
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-vimode
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable ctags geanyctags)
+ $(use_enable lua geanylua)
+ $(use_enable gpg geanypg)
+ $(use_enable git gitchangebar)
+ $(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
+ $(use_enable pretty-printer)
+ $(use_enable scope)
+ $(use_enable enchant spellcheck)
+ $(use_enable webhelper)
+ $(use_enable workbench)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # Require libsoup-2.4 which conflicts with webkit2gtk-4.1
+ --disable-geniuspaste
+ --disable-updatechecker
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -z "${LINGUAS-x}" ]]; then
+ rm -r "${ED}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index 6a11d0ae3243..28e3e26dec86 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -1,25 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>aklhfex@gmail.com</email>
<name>Chris Mayo</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
<use>
- <flag name="gtk3">Use GTK+3 instead of GTK+2</flag>
<flag name="ctags">Enable ctags plugin</flag>
- <flag name="debugger">Enable the debugger plugin which interfaces with <pkg>sys-devel/gdb</pkg></flag>
+ <flag name="debugger">Enable the debugger plugin which interfaces with <pkg>dev-debug/gdb</pkg></flag>
<flag name="enchant">Enable spell checking using enchant</flag>
<flag name="gpg">Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
<flag name="gtkspell">Use gtkspell for dictionary support in GeanyVC</flag>
<flag name="markdown">Enable the markdown plugin</flag>
<flag name="pretty-printer">Enable pretty-printer plugin</flag>
<flag name="scope">Enable the scope plugin which is a graphical GDB front-end</flag>
- <flag name="soup">Enable updatechecker and geniuspaste plugins which require <pkg>net-libs/libsoup</pkg></flag>
+ <flag name="webhelper">Enable webhelper plugin</flag>
<flag name="workbench">Enable workbench plugin</flag>
</use>
</pkgmetadata>