summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gitchangelog')
-rw-r--r--dev-util/gitchangelog/Manifest2
-rw-r--r--dev-util/gitchangelog/gitchangelog-3.0.9.ebuild41
-rw-r--r--dev-util/gitchangelog/gitchangelog-3.1.2.ebuild57
-rw-r--r--dev-util/gitchangelog/metadata.xml5
4 files changed, 61 insertions, 44 deletions
diff --git a/dev-util/gitchangelog/Manifest b/dev-util/gitchangelog/Manifest
index cd663768e53e..a2da9e87f7b9 100644
--- a/dev-util/gitchangelog/Manifest
+++ b/dev-util/gitchangelog/Manifest
@@ -1 +1 @@
-DIST gitchangelog-3.0.9.tar.gz 52483 BLAKE2B 8e7fc61dee6cba6e630cb2006d5bec988ea3d7a7c1e09789b430e11d4c3d8f5e7ff7ee1231dbbcb56185c84fa9c2bbf6a353980f5a70c8a0cce51b2dce83fb5d SHA512 4e290d75455ddddb7d12d831dce973771f861d23d6b6548b8a9e24e838b0931255dfc8c9ef25765fb4f269d5cdad6bd207fbaa3626a3b24681efdbb56ad9e1b1
+DIST gitchangelog-3.1.2.tar.gz 93679 BLAKE2B ffd5a9bd25c8bc647c7414e0864a008bafa09b6d5452fa0241408fa324821d4d4faa3e05ac1157521dec5508240383064fb9baca112218d5555e12cc05807400 SHA512 390d90fe62799350044b0009cc05a9889b1d4cd2a1e10dcdc42c71202afcb2c6bb1cc49125b3f69b03c0bd6a5bc8a7c29da0d9feeb54ac6ce2e396c489e69384
diff --git a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
deleted file mode 100644
index d2e9d691c1bb..000000000000
--- a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTULS_USE_SETUPTOOLS="pyproject.toml"
-
-inherit distutils-r1
-
-DESCRIPTION="Creates a changelog from git log history"
-HOMEPAGE="https://github.com/sarnold/gitchangelog"
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://github.com/sarnold/gitchangelog.git"
- EGIT_BRANCH="master"
- inherit git-r3
-else
- SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-BDEPEND="${DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/minimock[${PYTHON_USEDEP}] )
-"
-
-DEPEND="${PYTHON_DEPS}
- dev-python/pystache[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
-"
-
-RESTRICT="!test? ( test )"
-
-python_test() {
- "${EPYTHON}" -m nose -sx . || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-util/gitchangelog/gitchangelog-3.1.2.ebuild b/dev-util/gitchangelog/gitchangelog-3.1.2.ebuild
new file mode 100644
index 000000000000..85d99c6cb0ce
--- /dev/null
+++ b/dev-util/gitchangelog/gitchangelog-3.1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Creates a nicely formatted changelog from git log history"
+HOMEPAGE="https://github.com/sarnold/gitchangelog"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/gitchangelog.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/minimock[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ dev-python/pystache[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+"
+
+# needs versioningit if building from git repo source
+if [[ ${PV} = 9999* ]]; then
+ BDEPEND="
+ $(python_gen_any_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')"
+fi
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx \
+ docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/recommonmark \
+ dev-python/sphinxcontrib-apidoc
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --doctest-modules .
+}
diff --git a/dev-util/gitchangelog/metadata.xml b/dev-util/gitchangelog/metadata.xml
index 14d417cfceb2..35fc060a9777 100644
--- a/dev-util/gitchangelog/metadata.xml
+++ b/dev-util/gitchangelog/metadata.xml
@@ -6,8 +6,9 @@
<name>Steve Arnold</name>
</maintainer>
<longdescription lang="en">
- Create a fancy changelog from git log history (in rst or md) and
- customize your config with Python callables and regex.
+ Create a fancy changelog from git log history (in rst or md). You can
+ customize your config with Python callables and custom regex, as well
+ as built-in or custom template files.
</longdescription>
<upstream>
<remote-id type="github">sarnold/gitchangelog</remote-id>