summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glslang/files')
-rw-r--r--dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch26
-rw-r--r--dev-util/glslang/files/glslang-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-files.patch105
2 files changed, 0 insertions, 131 deletions
diff --git a/dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch b/dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch
deleted file mode 100644
index 4c44cfbbbedd..000000000000
--- a/dev-util/glslang/files/glslang-7.12.3353_pre20191027-fix-relative-includes.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/SPIRV/GlslangToSpv.h b/SPIRV/GlslangToSpv.h
-index 86e1c23b..3907be43 100755
---- a/SPIRV/GlslangToSpv.h
-+++ b/SPIRV/GlslangToSpv.h
-@@ -40,7 +40,7 @@
- #endif
-
- #include "SpvTools.h"
--#include "../glslang/Include/intermediate.h"
-+#include "glslang/Include/intermediate.h"
-
- #include <string>
- #include <vector>
-diff --git a/SPIRV/SpvTools.h b/SPIRV/SpvTools.h
-index 7422d012..59c914da 100644
---- a/SPIRV/SpvTools.h
-+++ b/SPIRV/SpvTools.h
-@@ -46,7 +46,7 @@
- #include <ostream>
- #endif
-
--#include "../glslang/MachineIndependent/localintermediate.h"
-+#include "glslang/MachineIndependent/localintermediate.h"
- #include "Logger.h"
-
- namespace glslang {
diff --git a/dev-util/glslang/files/glslang-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-files.patch b/dev-util/glslang/files/glslang-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-files.patch
deleted file mode 100644
index 8838a97809d4..000000000000
--- a/dev-util/glslang/files/glslang-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-files.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff --git a/OGLCompilersDLL/CMakeLists.txt b/OGLCompilersDLL/CMakeLists.txt
-index af4ab587..e0096743 100644
---- a/OGLCompilersDLL/CMakeLists.txt
-+++ b/OGLCompilersDLL/CMakeLists.txt
-@@ -11,5 +11,5 @@ endif(WIN32)
- if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS OGLCompiler EXPORT OGLCompilerTargets
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-- install(EXPORT OGLCompilerTargets DESTINATION lib/cmake)
-+ install(EXPORT OGLCompilerTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)
-diff --git a/SPIRV/CMakeLists.txt b/SPIRV/CMakeLists.txt
-index e25ec0a1..364f04cc 100644
---- a/SPIRV/CMakeLists.txt
-+++ b/SPIRV/CMakeLists.txt
-@@ -91,8 +91,8 @@ if(ENABLE_GLSLANG_INSTALL)
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- endif()
-
-- install(EXPORT SPVRemapperTargets DESTINATION lib/cmake)
-- install(EXPORT SPIRVTargets DESTINATION lib/cmake)
-+ install(EXPORT SPVRemapperTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
-+ install(EXPORT SPIRVTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
-
- install(FILES ${HEADERS} ${SPVREMAP_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/glslang/SPIRV/)
- endif(ENABLE_GLSLANG_INSTALL)
-diff --git a/StandAlone/CMakeLists.txt b/StandAlone/CMakeLists.txt
-index 0878965c..d9d71d1a 100644
---- a/StandAlone/CMakeLists.txt
-+++ b/StandAlone/CMakeLists.txt
-@@ -49,12 +49,12 @@ if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS spirv-remap EXPORT spirv-remapTargets
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-
-- install(EXPORT glslangValidatorTargets DESTINATION lib/cmake)
-- install(EXPORT spirv-remapTargets DESTINATION lib/cmake)
-+ install(EXPORT glslangValidatorTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
-+ install(EXPORT spirv-remapTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
-
- if(BUILD_SHARED_LIBS)
- install(TARGETS glslang-default-resource-limits EXPORT glslang-default-resource-limitsTargets
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
-- install(EXPORT glslang-default-resource-limitsTargets DESTINATION lib/cmake)
-+ install(EXPORT glslang-default-resource-limitsTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif()
- endif(ENABLE_GLSLANG_INSTALL)
-diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
-index 42df1d1e..446cabb9 100644
---- a/glslang/CMakeLists.txt
-+++ b/glslang/CMakeLists.txt
-@@ -112,7 +112,7 @@ if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS glslang EXPORT glslangTargets
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- endif()
-- install(EXPORT glslangTargets DESTINATION lib/cmake)
-+ install(EXPORT glslangTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)
-
- if(ENABLE_GLSLANG_INSTALL)
-diff --git a/glslang/OSDependent/Unix/CMakeLists.txt b/glslang/OSDependent/Unix/CMakeLists.txt
-index 91fb45a7..9994314f 100644
---- a/glslang/OSDependent/Unix/CMakeLists.txt
-+++ b/glslang/OSDependent/Unix/CMakeLists.txt
-@@ -22,5 +22,5 @@ endif()
- if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS OSDependent EXPORT OSDependentTargets
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-- install(EXPORT OSDependentTargets DESTINATION lib/cmake)
-+ install(EXPORT OSDependentTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)
-diff --git a/glslang/OSDependent/Windows/CMakeLists.txt b/glslang/OSDependent/Windows/CMakeLists.txt
-index f6bd4e9d..c050ef61 100644
---- a/glslang/OSDependent/Windows/CMakeLists.txt
-+++ b/glslang/OSDependent/Windows/CMakeLists.txt
-@@ -17,5 +17,5 @@ endif(WIN32)
- if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS OSDependent EXPORT OSDependentTargets
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-- install(EXPORT OSDependentTargets DESTINATION lib/cmake)
-+ install(EXPORT OSDependentTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)
-diff --git a/gtests/CMakeLists.txt b/gtests/CMakeLists.txt
-index 77d217f1..aadf9a54 100644
---- a/gtests/CMakeLists.txt
-+++ b/gtests/CMakeLists.txt
-@@ -33,7 +33,7 @@ if(BUILD_TESTING)
- if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS glslangtests EXPORT glslangtestsTargets
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-- install(EXPORT glslangtestsTargets DESTINATION lib/cmake)
-+ install(EXPORT glslangtestsTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)
-
- set(GLSLANG_TEST_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/../Test")
-diff --git a/hlsl/CMakeLists.txt b/hlsl/CMakeLists.txt
-index 44f9d6a2..ae0d4d4e 100644
---- a/hlsl/CMakeLists.txt
-+++ b/hlsl/CMakeLists.txt
-@@ -41,5 +41,5 @@ if(ENABLE_GLSLANG_INSTALL)
- install(TARGETS HLSL EXPORT HLSLTargets
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- endif()
-- install(EXPORT HLSLTargets DESTINATION lib/cmake)
-+ install(EXPORT HLSLTargets DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
- endif(ENABLE_GLSLANG_INSTALL)