summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glslang/glslang-10.11.0.0_pre20201216.ebuild')
-rw-r--r--dev-util/glslang/glslang-10.11.0.0_pre20201216.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/glslang/glslang-10.11.0.0_pre20201216.ebuild b/dev-util/glslang/glslang-10.11.0.0_pre20201216.ebuild
new file mode 100644
index 000000000000..35e6ee8f2b12
--- /dev/null
+++ b/dev-util/glslang/glslang-10.11.0.0_pre20201216.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
+ inherit git-r3
+else
+ SNAPSHOT_COMMIT="c594de23cdd790d64ad5f9c8b059baae0ee2941d"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${SNAPSHOT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${SNAPSHOT_COMMIT}"
+fi
+
+DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
+HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="!<media-libs/shaderc-2020.1"
+BDEPEND="${PYTHON_DEPS}"
+
+# Bug 698850
+RESTRICT="test"