summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glslang/glslang-9999.ebuild')
-rw-r--r--dev-util/glslang/glslang-9999.ebuild33
1 files changed, 23 insertions, 10 deletions
diff --git a/dev-util/glslang/glslang-9999.ebuild b/dev-util/glslang/glslang-9999.ebuild
index ae66106f0080..016cbd9bdeea 100644
--- a/dev-util/glslang/glslang-9999.ebuild
+++ b/dev-util/glslang/glslang-9999.ebuild
@@ -1,28 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_ECLASS="cmake"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake-multilib python-any-r1
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ GIT_COMMIT="vulkan-sdk-${PV}"
+ SRC_URI="https://github.com/KhronosGroup/${PN}/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${GIT_COMMIT}"
fi
DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="!<media-libs/shaderc-2020.1"
-BDEPEND="${PYTHON_DEPS}"
+SLOT="0/14"
# Bug 698850
RESTRICT="test"
+
+BDEPEND="${PYTHON_DEPS}
+ ~dev-util/spirv-tools-${PV}:=[${MULTILIB_USEDEP}]
+"
+
+DEPEND="~dev-util/spirv-tools-${PV}:=[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PCH=OFF
+ -DALLOW_EXTERNAL_SPIRV_TOOLS=ON
+ )
+ cmake_src_configure
+}