summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gnome-builder')
-rw-r--r--dev-util/gnome-builder/Manifest2
-rw-r--r--dev-util/gnome-builder/files/44.2-fix-gtk-4.12.5-build.patch26
-rw-r--r--dev-util/gnome-builder/gnome-builder-3.40.2.ebuild183
-rw-r--r--dev-util/gnome-builder/gnome-builder-44.2-r1.ebuild288
-rw-r--r--dev-util/gnome-builder/metadata.xml26
5 files changed, 329 insertions, 196 deletions
diff --git a/dev-util/gnome-builder/Manifest b/dev-util/gnome-builder/Manifest
index 0b140c2c4500..42d2ecf2959c 100644
--- a/dev-util/gnome-builder/Manifest
+++ b/dev-util/gnome-builder/Manifest
@@ -1 +1 @@
-DIST gnome-builder-3.40.2.tar.xz 12083992 BLAKE2B 136c3e89378221116b5252a8472768888f11bd580cf9d1d524504f9000b8123ee479e19073630bb678cc7392b716e45d122b406dc7d44b13ba0ba77b435077e0 SHA512 e0d1f0f21fe0f681f87d1ad672cb5bf60df3ef16541fffd8ca62d447339371bdb5cbc10d8fc83496822d6eb35ad8078b095ff97d950d940d862d6fd7968147a4
+DIST gnome-builder-44.2.tar.xz 9788192 BLAKE2B 3e31997a840ea288db37d942aa5b5ff92dce6754a9fe5984e9e20334c7e0323835d279bee0744277cbe2f111076a932efa692d3e0e229230da3c0d782faa7442 SHA512 0e0bdf57b1467789b6fe221e484e2cce5e37dae0fe3c190db51ec0f150a0ced1eca574bebceefe4ca33d31b4f09f472a0853fce24b1ef3f5de82256fa01f6090
diff --git a/dev-util/gnome-builder/files/44.2-fix-gtk-4.12.5-build.patch b/dev-util/gnome-builder/files/44.2-fix-gtk-4.12.5-build.patch
new file mode 100644
index 000000000000..eccf90851fb7
--- /dev/null
+++ b/dev-util/gnome-builder/files/44.2-fix-gtk-4.12.5-build.patch
@@ -0,0 +1,26 @@
+From 43a7c586b7291b5cf82febdaa80b4fe4efea8f54 Mon Sep 17 00:00:00 2001
+From: Christian Hergert <chergert@redhat.com>
+Date: Mon, 15 Jan 2024 11:54:38 -0800
+Subject: [PATCH] libide/tweaks: remove autoptr cleanup
+
+This is not needed now with recent GTK changes merged this morning.
+---
+ src/libide/tweaks/ide-tweaks-window.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/libide/tweaks/ide-tweaks-window.c b/src/libide/tweaks/ide-tweaks-window.c
+index f2553a396..dcb55bb35 100644
+--- a/src/libide/tweaks/ide-tweaks-window.c
++++ b/src/libide/tweaks/ide-tweaks-window.c
+@@ -32,8 +32,6 @@
+ #include "ide-tweaks-panel-list-private.h"
+ #include "ide-tweaks-window.h"
+
+-G_DEFINE_AUTOPTR_CLEANUP_FUNC (GtkStackPage, g_object_unref)
+-
+ struct _IdeTweaksWindow
+ {
+ AdwWindow parent_instance;
+--
+2.43.0
+
diff --git a/dev-util/gnome-builder/gnome-builder-3.40.2.ebuild b/dev-util/gnome-builder/gnome-builder-3.40.2.ebuild
deleted file mode 100644
index 13087e7d6c33..000000000000
--- a/dev-util/gnome-builder/gnome-builder-3.40.2.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISABLE_AUTOFORMATTING=1
-FORCE_PRINT_ELOG=1
-
-inherit gnome.org gnome2-utils llvm meson optfeature python-single-r1 readme.gentoo-r1 virtualx xdg
-
-DESCRIPTION="An IDE for writing GNOME-based software"
-HOMEPAGE="https://wiki.gnome.org/Apps/Builder"
-
-# FIXME: Review licenses at some point
-LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="clang +devhelp doc +git +glade gtk-doc spell sysprof test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# When bumping, pay attention to all the included plugins/*/meson.build (and other) build files and the requirements within.
-# `grep -rI dependency * --include='meson.build'` can give a good initial idea for external deps and their double checking.
-# The listed RDEPEND order shold roughly match that output as well, with toplevel one first then sorted by file path.
-# Most plugins have no extra requirements and default to enabled; we need to handle the ones with extra requirements. Many of
-# them have optional runtime dependencies, for which we try to at least notify the user via DOC_CONTENTS (but not all small
-# things); `grep -rI -e 'command-pattern.*=' -e 'push_arg'` can give a (spammy) idea, plus python imports in try/except.
-
-# FIXME: plugin_flatpak needs flatpak.pc >=0.8.0, ostree-1, libsoup-2.4.pc >=2.52.0 and git plugin enabled
-# Editorconfig needs old pcre, with vte migrating away, might want it optional or ported to pcre2?
-# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it (grep for gi.repository). Last full check at 3.28.4
-
-# TODO: Handle llvm slots via llvm.eclass; see plugins/clang/meson.build
-# TODO: automagic libportal dep
-# TODO: automagic sysprof dep for tracing paths from toplevel meson.build
-RDEPEND="
- >=dev-libs/libdazzle-3.37.0[introspection]
- >=dev-libs/glib-2.67.4:2
- >=x11-libs/gtk+-3.22.26:3[introspection]
- >=x11-libs/gtksourceview-4.0.0:4[introspection]
- >=dev-libs/json-glib-1.2.0
- >=dev-libs/jsonrpc-glib-3.19.91
- >=x11-libs/pango-1.38.0
- >=dev-libs/libpeas-1.22.0[python,${PYTHON_SINGLE_USEDEP}]
- >=dev-libs/template-glib-3.28.0[introspection]
- >=x11-libs/vte-0.40.2:2.91[introspection]
- >=net-libs/webkit-gtk-2.26:4=[introspection]
- >=dev-libs/libxml2-2.9.0
- git? ( dev-libs/libgit2:=[ssh,threads]
- >=dev-libs/libgit2-glib-0.28.0.1[ssh]
- )
- dev-libs/libpcre:3
- dev-libs/libpcre2
-
- >=dev-libs/gobject-introspection-1.54.0:=
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
- ')
- ${PYTHON_DEPS}
- clang? ( sys-devel/clang:= )
- devhelp? ( >=dev-util/devhelp-3.25.1:= )
- glade? ( >=dev-util/glade-3.22.0:3.10= )
- spell? ( >=app-text/gspell-1.8:0=
- app-text/enchant:2 )
- sysprof? ( >=dev-util/sysprof-3.37.1:0/4[gtk] )
-"
-DEPEND="${RDEPEND}"
-# TODO: runtime ctags path finding..
-
-# desktop-file-utils required for tests, but we have it in deptree for xdg update-desktop-database anyway, so be explicit and unconditional
-# appstream-glib needed for validation with appstream-util with FEATURES=test
-BDEPEND="
- doc? ( $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- ') )
- gtk-doc? ( dev-util/gtk-doc
- app-text/docbook-xml-dtd:4.3 )
- test? (
- dev-libs/appstream-glib
- sys-apps/dbus )
- dev-util/desktop-file-utils
- dev-util/glib-utils
- >=dev-util/meson-0.49.2
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-DOC_CONTENTS='gnome-builder can use various other dependencies on runtime to provide
-extra capabilities beyond these expressed via USE flags. Some of these
-that are currently available with packages include:
-
-* dev-util/uncrustify and dev-python/autopep8 for various Code Beautifier
- plugin out of the box functionality.
-* dev-util/ctags with exuberant-ctags selected via "eselect ctags" for
- C, C++, Python, JavaScript, CSS, HTML and Ruby autocompletion, semantic
- highlighting and symbol resolving support.
-* dev-python/jedi and dev-python/lxml for more accurate Python
- autocompletion support.
-* dev-util/valgrind for integration with valgrind.
-* dev-util/meson for integration with the Meson build system.
-* dev-util/cargo for integration with the Rust Cargo build system.
-* dev-util/cmake for integration with the CMake build system.
-* net-libs/nodejs[npm] for integration with the NPM package system.
-'
-# FIXME: Package codespell and mention here
-# FIXME: Package gnome-code-assistance and mention here, or maybe USE flag and default enable because it's rather important
-# eslint for additional diagnostics in JavaScript files (what package has this? At least something via NPM..)
-# jhbuild support
-# rust support via rust-analyzer (rls plugin now disabled by default); Go via go-langserver
-# autotools stuff for autotools plugin; gtkmm/autoconf-archive for C++ template
-# gjs/gettext/mono/PHPize stuff, but most of these are probably installed for other reasons anyways, when needed inside IDE
-# stylelint for stylesheet (CSS and co) linting
-# gvls for vala language-server integration
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
- use clang && llvm_pkg_setup
-}
-
-src_configure() {
- local emesonargs=(
- -Dtracing=false
- -Dprofiling=false # not passing -pg to CFLAGS
- -Dtcmalloc=false
- -Dchannel=other
-
- $(meson_use doc help)
- $(meson_use gtk-doc docs)
-
- -Dnetwork_tests=false
- $(meson_use clang plugin_clang)
- -Dplugin_color_picker=false # needs libportal
- $(meson_use devhelp plugin_devhelp)
- -Dplugin_deviced=false
- -Dplugin_editorconfig=true # needs libpcre
- -Dplugin_flatpak=false
- $(meson_use git plugin_git)
- $(meson_use glade plugin_glade)
- -Dplugin_podman=false
- $(meson_use spell plugin_spellcheck)
- $(meson_use sysprof plugin_sysprof)
- -Dplugin_update_manager=false
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- python_optimize
- if use doc; then
- rm "${ED}"/usr/share/doc/gnome-builder/en/.buildinfo || die
- rm "${ED}"/usr/share/doc/gnome-builder/en/objects.inv || die
- # custom docdir in build system, blocked by https://github.com/mesonbuild/meson/issues/825
- mv "${ED}"/usr/share/doc/gnome-builder/en "${ED}"/usr/share/doc/${PF}/html || die
- # _sources subdir left in on purpose, as HTML links to the rst files as "View page source". Additionally default docompress exclusion of /html/ already ensures they aren't compressed, thus linkable as-is.
- rmdir "${ED}"/usr/share/doc/gnome-builder/ || die
- fi
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
- readme.gentoo_print_elog
-
- optfeature_header "Code beautifiers"
- optfeature "Python" dev-python/autopep8
- optfeature "C/C++/Java" dev-util/uncrustify
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
-
-src_test() {
- # FIXME: can't run meson_src_test together with virtx or dbus-run-session
- virtx dbus-run-session meson test -C "${BUILD_DIR}"
-}
diff --git a/dev-util/gnome-builder/gnome-builder-44.2-r1.ebuild b/dev-util/gnome-builder/gnome-builder-44.2-r1.ebuild
new file mode 100644
index 000000000000..8dd7656ce8b7
--- /dev/null
+++ b/dev-util/gnome-builder/gnome-builder-44.2-r1.ebuild
@@ -0,0 +1,288 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+
+inherit gnome.org gnome2-utils llvm meson optfeature python-single-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="An IDE for writing GNOME-based software"
+HOMEPAGE="https://wiki.gnome.org/Apps/Builder https://gitlab.gnome.org/GNOME/gnome-builder"
+
+# FIXME: Review licenses at some point
+LICENSE="GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+IUSE="clang doc +d-spy flatpak +git gtk-doc spell +sysprof test +webkit"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ flatpak? ( git )
+"
+
+# When bumping, pay attention to all the included plugins/*/meson.build (and other) build files and the requirements within.
+# `grep -rI dependency * --include='meson.build'` can give a good initial idea for external deps and their double checking.
+# The listed RDEPEND order should roughly match that output as well, with toplevel one first then sorted by file path.
+# Most plugins have no extra requirements and default to enabled; we need to handle the ones with extra requirements. Many of
+# them have optional runtime dependencies, for which we try to at least notify the user via DOC_CONTENTS (but not all small
+# things); `grep -rI -e 'command-pattern.*=' -e 'push_arg'` can give a (spammy) idea, plus python imports in try/except.
+
+# Editorconfig needs old pcre, with vte migrating away, might want it optional or ported to pcre2?
+# An introspection USE flag of a dep is required if any introspection based language plugin wants to use it (grep for gi.repository). Last full check at 3.28.4
+
+# >=gtk-4.12.5 for relying on GtkStackPage autoptr cleanup added in that version
+
+# TODO: Handle llvm slots via llvm.eclass; see plugins/clang/meson.build
+RDEPEND="
+ >=dev-libs/glib-2.75.0:2
+ >=gui-libs/gtk-4.12.5:4[introspection]
+ >=gui-libs/libadwaita-1.3.0:1
+ >=gui-libs/libpanel-1.1.2:1
+ >=gui-libs/gtksourceview-5.7.2:5[introspection]
+ >=dev-libs/json-glib-1.2.0
+ >=dev-libs/jsonrpc-glib-3.43.0:=
+ >=dev-libs/libdex-0.1.1:=
+ >=dev-libs/libpeas-1.34.0:0[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libportal:=[gtk,introspection]
+ >=dev-libs/template-glib-3.36.1:=[introspection]
+ >=gui-libs/vte-0.70.0:2.91-gtk4[introspection]
+ >=dev-libs/libxml2-2.9.0
+ webkit? ( >=net-libs/webkit-gtk-2.38.0:6=[introspection] )
+ >=app-text/cmark-0.29.0:0=
+ d-spy? ( >=dev-debug/d-spy-1.4.0:1 )
+ app-text/editorconfig-core-c
+ flatpak? (
+ dev-util/ostree
+ >=net-libs/libsoup-3:3.0
+ >=sys-apps/flatpak-1.10.2
+ )
+ git? (
+ dev-libs/libgit2:=[ssh,threads]
+ >=dev-libs/libgit2-glib-1.1.0[ssh]
+ )
+
+ >=dev-libs/gobject-introspection-1.54.0:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ clang? ( sys-devel/clang:= )
+ spell? (
+ app-text/enchant:2
+ dev-libs/icu:=
+ )
+ sysprof? (
+ >=dev-util/sysprof-capture-3.46.0:4
+ >=dev-util/sysprof-3.46.0:0/4
+ )
+"
+DEPEND="${RDEPEND}"
+# TODO: runtime ctags path finding..
+
+# desktop-file-utils required for tests, but we have it in deptree for xdg update-desktop-database anyway, so be explicit and unconditional
+# appstream-glib needed for validation with appstream-util with FEATURES=test
+BDEPEND="
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
+ ')
+ )
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.3
+ )
+ test? (
+ dev-libs/appstream-glib
+ sys-apps/dbus
+ )
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS='gnome-builder can use various other dependencies on runtime to provide
+extra capabilities beyond these expressed via USE flags. Some of these
+that are currently available with packages include:
+
+* dev-util/ctags with exuberant-ctags selected via "eselect ctags" for
+ C, C++, Python, JavaScript, CSS, HTML and Ruby autocompletion, semantic
+ highlighting and symbol resolving support.
+* dev-python/python-lsp-server for more accurate Python
+ autocompletion support.
+* dev-debug/valgrind for integration with valgrind.
+* dev-build/meson for integration with the Meson build system.
+* virtual/rust for integration with the Rust Cargo build system.
+* dev-build/cmake for integration with the CMake build system.
+* net-libs/nodejs[npm] for integration with the NPM package system.
+'
+# FIXME: Package codespell and mention here
+# FIXME: Package gnome-code-assistance and mention here, or maybe USE flag and default enable because it's rather important
+# eslint for additional diagnostics in JavaScript files (what package has this? At least something via NPM..)
+# jhbuild support
+# rust support via rust-analyzer; Go via go-langserver
+# autotools stuff for autotools plugin; gtkmm/autoconf-archive for C++ template
+# gjs/gettext/mono/PHPize stuff, but most of these are probably installed for other reasons anyways, when needed inside IDE
+# stylelint for stylesheet (CSS and co) linting
+# gvls for vala language-server integration
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-gtk-4.12.5-build.patch
+)
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ use clang && llvm_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fails with clang due to `environ` variable name shadowing unistd.h one
+ sed -i -e '/-Werror=shadow/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dchannel=other
+
+ -Ddevelopment=false
+ -Dtracing=false
+ -Dprofiling=false # not passing -pg to CFLAGS
+ -Dtcmalloc=false
+ -Dwith_safe_path=''
+ -Dgnome_sdk_version=master
+ $(meson_use doc help)
+ $(meson_use gtk-doc docs)
+ -Dnetwork_tests=false
+ -Dctags_path=''
+ $(meson_feature webkit)
+
+ -Dplugin_autotools=true
+ -Dplugin_bash_language_server=true
+ -Dplugin_blueprint=true
+ -Dplugin_buildstream=true
+ -Dplugin_c_pack=true
+ -Dplugin_cargo=true
+ $(meson_use clang plugin_clang)
+ $(meson_use clang plugin_clangd)
+ $(meson_use clang plugin_clang_format)
+ -Dplugin_cmake=true
+ -Dplugin_codesearch=true
+ -Dplugin_codeshot=true
+ -Dplugin_codespell=true
+ -Dplugin_code_index=true
+ -Dplugin_copyright=true
+ -Dplugin_ctags=true
+ -Dplugin_deviced=false # libdeviced not packaged?
+ $(meson_use d-spy plugin_dspy)
+ -Dplugin_dub=true
+ -Dplugin_editorconfig=true
+ -Dplugin_eslint=true
+ -Dplugin_file_search=true
+ $(meson_use flatpak plugin_flatpak)
+ -Dplugin_gdb=true
+ -Dplugin_gdiagnose=true
+ -Dplugin_gettext=true
+ $(meson_use git plugin_git)
+ -Dplugin_glsl_language_server=true
+ -Dplugin_golang=true
+ -Dplugin_gopls=true
+ -Dplugin_gradle=true
+ -Dplugin_grep=true
+ -Dplugin_hadolint=true
+ -Dplugin_html_completion=true
+ $(meson_use webkit plugin_html_preview)
+ -Dplugin_intelephense=true
+ -Dplugin_jdtls=true
+ -Dplugin_jedi_language_server=false
+ -Dplugin_jhbuild=true
+ -Dplugin_lua_language_server=true
+ -Dplugin_make=true
+ -Dplugin_make_templates=true
+ $(meson_use webkit plugin_markdown_preview)
+ $(meson_use webkit plugin_markdown_indenter)
+ -Dplugin_maven=true
+ -Dplugin_meson=true
+ -Dplugin_meson_templates=true
+ -Dplugin_modelines=true
+ -Dplugin_mono=true
+ -Dplugin_newcomers=true
+ -Dplugin_notification=true
+ -Dplugin_npm=true
+ -Dplugin_phpize=true
+ -Dplugin_podman=true
+ -Dplugin_pygi=true
+ -Dplugin_python_lsp_server=true
+ -Dplugin_qemu=true
+ -Dplugin_quick_highlight=true
+ -Dplugin_retab=true
+ -Dplugin_rstcheck=true
+ -Dplugin_rubocop=true
+ -Dplugin_rust_analyzer=false # rust-analyzer not packaged
+ -Dplugin_serve_d=true
+ -Dplugin_shellcheck=true
+ -Dplugin_shellcmd=true
+ -Dplugin_sourcekit_lsp=true
+ $(meson_use spell plugin_spellcheck)
+ $(meson_use webkit plugin_sphinx_preview)
+ -Dplugin_stylelint=true
+ -Dplugin_swift=true
+ -Dplugin_swiftformat=true
+ -Dplugin_swiftlint=true
+ $(meson_use sysprof plugin_sysprof)
+ -Dplugin_todo=true
+ -Dplugin_ts_language_server=true
+ -Dplugin_update_manager=true
+ -Dplugin_valac=true
+ -Dplugin_vala_indenter=true
+ -Dplugin_vala_language_server=true
+ -Dplugin_valgrind=true
+ -Dplugin_waf=true
+ -Dplugin_words=true
+ -Dplugin_xml_pack=true
+ -Dplugin_zls=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+ if use doc; then
+ rm "${ED}"/usr/share/doc/gnome-builder/en/.buildinfo || die
+ rm "${ED}"/usr/share/doc/gnome-builder/en/objects.inv || die
+ # custom docdir in build system, blocked by https://github.com/mesonbuild/meson/issues/825
+ mv "${ED}"/usr/share/doc/gnome-builder/en "${ED}"/usr/share/doc/${PF}/html || die
+ # _sources subdir left in on purpose, as HTML links to the rst files as "View page source". Additionally default docompress exclusion of /html/ already ensures they aren't compressed, thus linkable as-is.
+ rmdir "${ED}"/usr/share/doc/gnome-builder/ || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+
+ optfeature_header "Language support"
+ optfeature "Rust's Cargo build system" virtual/rust
+ optfeature "CMake" dev-build/cmake
+ optfeature "Java Maven build system" dev-java/maven-bin
+ optfeature "Meson Build system" dev-build/meson
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}
diff --git a/dev-util/gnome-builder/metadata.xml b/dev-util/gnome-builder/metadata.xml
index 342b0c570e2c..08976bc31e33 100644
--- a/dev-util/gnome-builder/metadata.xml
+++ b/dev-util/gnome-builder/metadata.xml
@@ -1,16 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="clang">Provide integration with <pkg>sys-devel/clang</pkg> for best possible C/C++ autocompletion, semantic highlighting, symbol resolving, and diagnostics support</flag>
- <flag name="devhelp">Provide API docs browsing and integration via <pkg>dev-util/devhelp</pkg></flag>
- <flag name="git">Provide support for the Git version control system via <pkg>dev-libs/libgit2-glib</pkg>
- (such as setup of Git for New Project, direct cloning for Open Project and changed lines indicators in the editor gutter)</flag>
- <flag name="glade">Provide integration with <pkg>dev-util/glade</pkg> UI designer for Gtk</flag>
- <flag name="sysprof">Provide an integrated profiler via <pkg>dev-util/sysprof</pkg></flag>
-</use>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="clang">Provide integration with <pkg>sys-devel/clang</pkg> for best possible C/C++ autocompletion, semantic highlighting, symbol resolving, and diagnostics support</flag>
+ <flag name="d-spy">Provide D-Bus debugging functionality via <pkg>dev-debug/d-spy</pkg></flag>
+ <flag name="flatpak">Enable support for flatpak applications using <pkg>sys-apps/flatpak</pkg></flag>
+ <flag name="git">Provide support for the Git version control system via <pkg>dev-libs/libgit2-glib</pkg> (such as setup of Git for New Project, direct cloning for Open Project and changed lines indicators in the editor gutter)</flag>
+ <flag name="sysprof">Provide an integrated profiler via <pkg>dev-util/sysprof</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/gnome-builder</remote-id>
+ </upstream>
</pkgmetadata>