summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/Manifest3
-rw-r--r--dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch13
-rw-r--r--dev-util/google-perftools/files/gperftools-2.0-32bit-barrier.patch17
-rw-r--r--dev-util/google-perftools/google-perftools-2.0-r2.ebuild71
-rw-r--r--dev-util/google-perftools/google-perftools-2.4.ebuild85
-rw-r--r--dev-util/google-perftools/google-perftools-2.6.3.ebuild85
6 files changed, 0 insertions, 274 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 9979b0356e53..35df40d4523e 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,5 +1,2 @@
-DIST gperftools-2.0.tar.gz 1261243 BLAKE2B a37c62f6f3c27a29036955c37a58c480e5cc628bd49036e20fe616e610d45b6727b0782605892a543cb477c388093feb5527e6557c5bc8446aaf874e946884f6 SHA512 61bf7a26974058912a4165cbc363351bc735599d36ab569dc7e84a75a690adbc17a4178512a57469fc7c17befaad2a271ef4ea5c29a36b664153938939269926
-DIST gperftools-2.4.tar.gz 890402 BLAKE2B f4893d7c9bbd3a8dc5b4d8a25837039261fa32782e13653991002ab666d6e81de637932a8b46c66df219336adcc395a217a4ce32332e8e1558beeb140ea642f2 SHA512 77198c150ee26579adc8f190be0c4ba90a9e3854b006c3aa9252b5863b1fce317fd690c6aa0ed202c81f0bbcfbe2d5f8a182263e77b7fb4fbc6b3e8bfffc9fb0
DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
-DIST gperftools-2.6.3.tar.gz 911813 BLAKE2B dae223927835f65b819836b25595df2943a0762ac3b6346e3d0186dab486cfa3e4eabc1f5a2ec43314f53ea96a68acb75991b76055591395bc52e78f655630d3 SHA512 6418c382760c8870ef42a535fcb65a623c1a9fd3ab58fcb7cfe2dd5048b2268b434427da36bc0c76beef2c28e13a6926d32d67084d8ca6675b78650a62de77a7
DIST gperftools-2.7.tar.gz 916919 BLAKE2B c48882df45415110c1ec39298e84ec9384f6a82851d95e92435649d2b253b9fb8e29664b474e45881599abf3781731c47ead0b6c454c33be9a207a6a2401a97c SHA512 9aa39689bc18603123204f024ab6dc96099b70a3d304e31ef0cc1e9893cc77bd14ee6eb420e597d40e81e487a2a45e77cf1965873646d056fd4b7bee22a4b0bb
diff --git a/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch b/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch
deleted file mode 100644
index b17e0d57f5fb..000000000000
--- a/dev-util/google-perftools/files/gperftools-2.0+glibc-2.16.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: gperftools-2.0/src/base/linuxthreads.cc
-===================================================================
---- gperftools-2.0.orig/src/base/linuxthreads.cc
-+++ gperftools-2.0/src/base/linuxthreads.cc
-@@ -193,7 +193,7 @@ static volatile int *sig_pids, sig_num_t
- /* Signal handler to help us recover from dying while we are attached to
- * other threads.
- */
--static void SignalHandler(int signum, siginfo_t *si, void *data) {
-+static void SignalHandler(int signum, struct siginfo *si, void *data) {
- if (sig_pids != NULL) {
- if (signum == SIGABRT) {
- while (sig_num_threads-- > 0) {
diff --git a/dev-util/google-perftools/files/gperftools-2.0-32bit-barrier.patch b/dev-util/google-perftools/files/gperftools-2.0-32bit-barrier.patch
deleted file mode 100644
index df89a92ed010..000000000000
--- a/dev-util/google-perftools/files/gperftools-2.0-32bit-barrier.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Atomic64 not available on all architectures.
-Use AtomicWord instead.
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nuar gperftools-2.0.orig/src/base/spinlock_internal.cc gperftools-2.0/src/base/spinlock_internal.cc
---- gperftools-2.0.orig/src/base/spinlock_internal.cc 2012-02-02 21:36:23.000000000 +0000
-+++ gperftools-2.0/src/base/spinlock_internal.cc 2013-01-20 23:44:01.629077919 +0000
-@@ -80,7 +80,7 @@
- static int SuggestedDelayNS(int loop) {
- // Weak pseudo-random number generator to get some spread between threads
- // when many are spinning.
-- static base::subtle::Atomic64 rand;
-+ static AtomicWord rand;
- uint64 r = base::subtle::NoBarrier_Load(&rand);
- r = 0x5deece66dLL * r + 0xb; // numbers from nrand48()
- base::subtle::NoBarrier_Store(&rand, r);
diff --git a/dev-util/google-perftools/google-perftools-2.0-r2.ebuild b/dev-util/google-perftools/google-perftools-2.0-r2.ebuild
deleted file mode 100644
index c0b175dcf38d..000000000000
--- a/dev-util/google-perftools/google-perftools-2.0-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_P="gperftools-${PV}"
-
-inherit toolchain-funcs eutils flag-o-matic autotools-utils
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* amd64 arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="largepages +debug minimal test static-libs"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-HTML_DOCS="doc"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${MY_P}+glibc-2.16.patch"
- epatch "${FILESDIR}/${MY_P}-32bit-barrier.patch"
-}
-
-src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- local myeconfargs=(
- --htmldir=/usr/share/doc/${PF}/html
- $(use_enable debug debugalloc)
- $(use_enable minimal)
- )
-
- autotools-utils_src_configure
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sanbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- autotools-utils_src_test
-}
diff --git a/dev-util/google-perftools/google-perftools-2.4.ebuild b/dev-util/google-perftools/google-perftools-2.4.ebuild
deleted file mode 100644
index a2986988f31c..000000000000
--- a/dev-util/google-perftools/google-perftools-2.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="gperftools-${PV}"
-inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="largepages +debug minimal optimisememory test static-libs"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-HTML_DOCS="doc"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- default
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --htmldir=/usr/share/doc/${PF}/html \
- --docdir=/usr/share/doc/${PF} \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug debugalloc) \
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sandbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- multilib-minimal_src_test
-}
-
-src_install() {
- if ! use minimal && has x32 ${MULTILIB_ABIS}; then
- MULTILIB_WRAPPED_HEADERS=(
- /usr/include/gperftools/heap-checker.h
- /usr/include/gperftools/heap-profiler.h
- /usr/include/gperftools/stacktrace.h
- /usr/include/gperftools/profiler.h
- )
- fi
-
- multilib-minimal_src_install
-}
diff --git a/dev-util/google-perftools/google-perftools-2.6.3.ebuild b/dev-util/google-perftools/google-perftools-2.6.3.ebuild
deleted file mode 100644
index 708d67991674..000000000000
--- a/dev-util/google-perftools/google-perftools-2.6.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="gperftools-${PV}"
-inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="largepages +debug minimal optimisememory test static-libs"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-HTML_DOCS="docs"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- default
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --htmldir=${EPREFIX}/usr/share/doc/${PF}/html \
- --docdir=${EPREFIX}/usr/share/doc/${PF} \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug debugalloc) \
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sandbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- multilib-minimal_src_test
-}
-
-src_install() {
- if ! use minimal && has x32 ${MULTILIB_ABIS}; then
- MULTILIB_WRAPPED_HEADERS=(
- /usr/include/gperftools/heap-checker.h
- /usr/include/gperftools/heap-profiler.h
- /usr/include/gperftools/stacktrace.h
- /usr/include/gperftools/profiler.h
- )
- fi
-
- multilib-minimal_src_install
-}