summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild')
-rw-r--r--dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild b/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
deleted file mode 100644
index 4579692ec843..000000000000
--- a/dev-util/gprof2dot/gprof2dot-0_p20130517.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE='xml'
-
-inherit eutils python-r1
-
-DESCRIPTION="Converts profiling output to dot graphs"
-HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
-SRC_URI="http://www.hartwork.org/public/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-py3-xrange.patch
-}
-
-_make_call_script() {
- cat <<-EOF >"${ED}/$1"
- #! /usr/bin/env python
- from gprof2dot import Main
- Main().main()
- EOF
-
- fperms a+x "$1" || die
-}
-
-src_install() {
- abi_specific_install() {
- local sitedir="$(python_get_sitedir)"
- insinto ${sitedir#"${EPREFIX}"}
- doins ${PN}.py || die
- python_optimize || die
- }
- python_foreach_impl abi_specific_install
-
- dodir /usr/bin || die
- _make_call_script /usr/bin/${PN} || die
- python_replicate_script "${ED}"/usr/bin/${PN} || die
-}