summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gprof2dot/gprof2dot-2017.09.19.ebuild')
-rw-r--r--dev-util/gprof2dot/gprof2dot-2017.09.19.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-2017.09.19.ebuild b/dev-util/gprof2dot/gprof2dot-2017.09.19.ebuild
new file mode 100644
index 000000000000..b113da87a395
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-2017.09.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_PV=${PV//.0/.}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}