summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hip/files')
-rw-r--r--dev-util/hip/files/hip-3.5.1-config-cmake-in.patch28
-rw-r--r--dev-util/hip/files/hip-3.5.1-detect_offload-arch_for_clang-roc.patch21
-rw-r--r--dev-util/hip/files/hip-3.5.1-hip_vector_types.patch10
-rw-r--r--dev-util/hip/files/hip-3.9.0-DisableTest.patch87
-rw-r--r--dev-util/hip/files/hip-3.9.0-add-include-directories.patch13
-rw-r--r--dev-util/hip/files/hip-3.9.0-lpl_ca-add-include.patch10
-rw-r--r--dev-util/hip/files/hip-4.1.0-DisableTest.patch37
-rw-r--r--dev-util/hip/files/hip-4.3.0-hip_vector_types.patch11
8 files changed, 0 insertions, 217 deletions
diff --git a/dev-util/hip/files/hip-3.5.1-config-cmake-in.patch b/dev-util/hip/files/hip-3.5.1-config-cmake-in.patch
deleted file mode 100644
index f3b5ac9c19ef..000000000000
--- a/dev-util/hip/files/hip-3.5.1-config-cmake-in.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/hip-config.cmake.in 2020-06-21 21:17:35.576297760 +0200
-+++ b/hip-config.cmake.in 2020-06-21 21:17:59.861296628 +0200
-@@ -123,8 +123,10 @@
- )
- set_target_properties(hip::device PROPERTIES
- INTERFACE_COMPILE_DEFINITIONS "__HIP_ROCclr__=1"
-- INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/../include"
-- INTERFACE_SYSTEM_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/../include"
-+ INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/include"
-+ INTERFACE_SYSTEM_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/include"
-+# INTERFACE_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/../include"
-+# INTERFACE_SYSTEM_INCLUDE_DIRECTORIES "${_IMPORT_PREFIX}/../include"
- )
- else()
- set_target_properties(hip::hip_hcc_static PROPERTIES
-@@ -156,9 +158,9 @@
- INTERFACE_LINK_LIBRARIES --hip-device-lib-path=${AMD_DEVICE_LIBS_PREFIX}/lib --hip-link
- )
-
-- set_property(TARGET hip::device APPEND PROPERTY
-- INTERFACE_INCLUDE_DIRECTORIES "${HIP_CLANG_INCLUDE_PATH}/.."
-- )
-+# set_property(TARGET hip::device APPEND PROPERTY
-+# INTERFACE_INCLUDE_DIRECTORIES "${HIP_CLANG_INCLUDE_PATH}/.."
-+# )
-
- set_property(TARGET hip::device APPEND PROPERTY
- INTERFACE_SYSTEM_INCLUDE_DIRECTORIES "${HIP_CLANG_INCLUDE_PATH}/.."
diff --git a/dev-util/hip/files/hip-3.5.1-detect_offload-arch_for_clang-roc.patch b/dev-util/hip/files/hip-3.5.1-detect_offload-arch_for_clang-roc.patch
deleted file mode 100644
index 7997e2929666..000000000000
--- a/dev-util/hip/files/hip-3.5.1-detect_offload-arch_for_clang-roc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -uprN HIP-rocm-3.5.1/bin/hipcc patched/bin/hipcc
---- HIP-rocm-3.5.1/bin/hipcc 2020-07-21 14:29:11.625878447 +0800
-+++ patched/bin/hipcc 2020-07-21 14:34:11.454395203 +0800
-@@ -675,7 +675,7 @@ foreach $arg (@ARGV)
- $prevArg = $arg;
- }
-
--if($HIP_PLATFORM eq "hcc"){
-+if($HIP_PLATFORM eq "hcc" || $HIP_PLATFORM eq "rocclr"){
- # No AMDGPU target specified at commandline. So look for HCC_AMDGPU_TARGET
- if($default_amdgpu_target eq 1) {
- if (defined $ENV{HCC_AMDGPU_TARGET}) {
-@@ -694,6 +694,8 @@ if($HIP_PLATFORM eq "hcc"){
-
- if($HIP_COMPILER eq "hcc") {
- $GPU_ARCH_OPT = " --amdgpu-target=";
-+ } elsif($HIP_COMPILER eq "clang") {
-+ $GPU_ARCH_OPT = " --offload-arch=";
- } else {
- $GPU_ARCH_OPT = " --cuda-gpu-arch=";
- }
diff --git a/dev-util/hip/files/hip-3.5.1-hip_vector_types.patch b/dev-util/hip/files/hip-3.5.1-hip_vector_types.patch
deleted file mode 100644
index 382ed52f6923..000000000000
--- a/dev-util/hip/files/hip-3.5.1-hip_vector_types.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/hip/hcc_detail/hip_vector_types.h
-+++ b/include/hip/hcc_detail/hip_vector_types.h
-@@ -42,6 +42,7 @@
- #endif
-
- #if defined(__cplusplus)
-+ #include <new>
- #include <array>
- #include <iosfwd>
- #include <type_traits>
diff --git a/dev-util/hip/files/hip-3.9.0-DisableTest.patch b/dev-util/hip/files/hip-3.9.0-DisableTest.patch
deleted file mode 100644
index 3fc787a7354e..000000000000
--- a/dev-util/hip/files/hip-3.9.0-DisableTest.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- a/CMakeLists.txt 2020-11-15 11:26:09.747793881 +0100
-+++ b/CMakeLists.txt 2020-11-15 11:28:45.289793287 +0100
-@@ -676,45 +676,45 @@
- # Target: test
- set(HIP_ROOT_DIR ${CMAKE_CURRENT_BINARY_DIR})
- set(HIP_SRC_PATH ${CMAKE_CURRENT_SOURCE_DIR})
--if(HIP_PLATFORM STREQUAL "nvcc")
-- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${CMAKE_CURRENT_BINARY_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--endif()
--execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--if(${RUN_HIT} EQUAL 0)
-- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--endif()
--if(${RUN_HIT} EQUAL 0)
-- set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
-- include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
--
-- # Add tests
-- include_directories(${HIP_SRC_PATH}/tests/src)
-- hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/src "directed_tests")
--
-- # Add unit tests
-- include_directories(${HIP_SRC_PATH}/tests/unit)
-- hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/unit "unit_tests")
--
-- # Add performance tests
-- include_directories(${HIP_SRC_PATH}/tests/performance)
-- hit_add_directory_recursive(${HIP_CTEST_CONFIG_PERFORMANCE} ${HIP_SRC_PATH}/tests/performance "performance_tests")
--
-- # Add top-level tests to build_tests
-- add_custom_target(build_tests DEPENDS directed_tests unit_tests)
--
-- # Add top-level tests to build performance_tests.
-- # To build performance tests, just run "make build_perf"
-- add_custom_target(build_perf DEPENDS performance_tests)
--
-- # Add custom target: perf.
-- # To run performance tests, just run "make perf"
-- add_custom_target(perf COMMAND "${CMAKE_CTEST_COMMAND}" -C "${HIP_CTEST_CONFIG_PERFORMANCE}" -R "performance_tests/" --verbose)
--
-- # Add custom target: check
-- add_custom_target(check COMMAND "${CMAKE_COMMAND}" --build . --target test DEPENDS build_tests)
--else()
-- message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
--endif()
-+#if(HIP_PLATFORM STREQUAL "nvcc")
-+# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${CMAKE_CURRENT_BINARY_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#endif()
-+#execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#if(${RUN_HIT} EQUAL 0)
-+# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#endif()
-+#if(${RUN_HIT} EQUAL 0)
-+# set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
-+# include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
-+#
-+# # Add tests
-+# include_directories(${HIP_SRC_PATH}/tests/src)
-+# hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/src "directed_tests")
-+#
-+# # Add unit tests
-+# include_directories(${HIP_SRC_PATH}/tests/unit)
-+# hit_add_directory_recursive(${HIP_CTEST_CONFIG_DEFAULT} ${HIP_SRC_PATH}/tests/unit "unit_tests")
-+#
-+# # Add performance tests
-+# include_directories(${HIP_SRC_PATH}/tests/performance)
-+# hit_add_directory_recursive(${HIP_CTEST_CONFIG_PERFORMANCE} ${HIP_SRC_PATH}/tests/performance "performance_tests")
-+#
-+# # Add top-level tests to build_tests
-+# add_custom_target(build_tests DEPENDS directed_tests unit_tests)
-+#
-+# # Add top-level tests to build performance_tests.
-+# # To build performance tests, just run "make build_perf"
-+# add_custom_target(build_perf DEPENDS performance_tests)
-+#
-+# # Add custom target: perf.
-+# # To run performance tests, just run "make perf"
-+# add_custom_target(perf COMMAND "${CMAKE_CTEST_COMMAND}" -C "${HIP_CTEST_CONFIG_PERFORMANCE}" -R "performance_tests/" --verbose)
-+#
-+# # Add custom target: check
-+# add_custom_target(check COMMAND "${CMAKE_COMMAND}" --build . --target test DEPENDS build_tests)
-+#else()
-+# message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
-+#endif()
-
- #############################
- # Code analysis
diff --git a/dev-util/hip/files/hip-3.9.0-add-include-directories.patch b/dev-util/hip/files/hip-3.9.0-add-include-directories.patch
deleted file mode 100644
index 42bd9736ee2c..000000000000
--- a/dev-util/hip/files/hip-3.9.0-add-include-directories.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/rocclr/CMakeLists.txt 2020-08-23 11:45:13.148817894 +0200
-+++ b/rocclr/CMakeLists.txt 2020-08-23 11:50:12.409816752 +0200
-@@ -139,6 +139,10 @@
- target_compile_definitions(hip64
- PRIVATE
- $<TARGET_PROPERTY:amdrocclr_static,INTERFACE_COMPILE_DEFINITIONS>)
-+
-+ include_directories(/usr/include/rocclr)
-+ include_directories(/usr/include/rocclr/elf)
-+ include_directories(/usr/include/rocclr/compiler/lib/include/)
- endif()
-
- # Enable profiling API
diff --git a/dev-util/hip/files/hip-3.9.0-lpl_ca-add-include.patch b/dev-util/hip/files/hip-3.9.0-lpl_ca-add-include.patch
deleted file mode 100644
index bebe6f0f4ecc..000000000000
--- a/dev-util/hip/files/hip-3.9.0-lpl_ca-add-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/lpl_ca/CMakeLists.txt 2020-11-15 11:47:55.091788901 +0100
-+++ b/lpl_ca/CMakeLists.txt 2020-11-15 11:49:14.881788597 +0100
-@@ -17,6 +17,7 @@
- ${PROJECT_SOURCE_DIR}/src
- PRIVATE
- $<TARGET_PROPERTY:amdrocclr_static,INTERFACE_INCLUDE_DIRECTORIES>)
-+target_include_directories(lpl SYSTEM PUBLIC /usr/include/rocclr/elf)
-
- target_compile_options(lpl PUBLIC -Wall)
- target_link_libraries(lpl PUBLIC pthread)
diff --git a/dev-util/hip/files/hip-4.1.0-DisableTest.patch b/dev-util/hip/files/hip-4.1.0-DisableTest.patch
deleted file mode 100644
index 49e7171b2f0d..000000000000
--- a/dev-util/hip/files/hip-4.1.0-DisableTest.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/CMakeLists.txt 2021-03-28 18:02:34.755857717 +0200
-+++ b/CMakeLists.txt 2021-03-28 18:04:54.217854203 +0200
-@@ -474,20 +474,20 @@
- #############################
- set(HIP_ROOT_DIR ${CMAKE_CURRENT_BINARY_DIR})
- set(HIP_SRC_PATH ${CMAKE_CURRENT_SOURCE_DIR})
--if(HIP_PLATFORM STREQUAL "nvidia")
-- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${HIP_ROOT_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--endif()
--execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--if(${RUN_HIT} EQUAL 0)
-- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
--endif()
--if(${RUN_HIT} EQUAL 0)
-- set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
-- include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
-- include(${HIP_SRC_PATH}/tests/Tests.cmake)
--else()
-- message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
--endif()
-+#if(HIP_PLATFORM STREQUAL "nvidia")
-+# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${HIP_ROOT_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#endif()
-+#execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#if(${RUN_HIT} EQUAL 0)
-+# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
-+#endif()
-+#if(${RUN_HIT} EQUAL 0)
-+# set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
-+# include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
-+# include(${HIP_SRC_PATH}/tests/Tests.cmake)
-+#else()
-+# message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
-+#endif()
-
- #############################
- # Code analysis
diff --git a/dev-util/hip/files/hip-4.3.0-hip_vector_types.patch b/dev-util/hip/files/hip-4.3.0-hip_vector_types.patch
deleted file mode 100644
index faad9629740f..000000000000
--- a/dev-util/hip/files/hip-4.3.0-hip_vector_types.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-mitigate compilation error
---- a/include/hip/amd_detail/hip_vector_types.h
-+++ b/include/hip/amd_detail/hip_vector_types.h
-@@ -45,6 +45,7 @@ THE SOFTWARE.
-
- #if defined(__cplusplus)
- #if !defined(__HIPCC_RTC__)
-+ #include <new>
- #include <array>
- #include <iosfwd>
- #include <type_traits>