summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hip/hip-5.3.3-r3.ebuild')
-rw-r--r--dev-util/hip/hip-5.3.3-r3.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-util/hip/hip-5.3.3-r3.ebuild b/dev-util/hip/hip-5.3.3-r3.ebuild
index c11b85e3f2ec..b4f51b3ef7b0 100644
--- a/dev-util/hip/hip-5.3.3-r3.ebuild
+++ b/dev-util/hip/hip-5.3.3-r3.ebuild
@@ -101,6 +101,10 @@ src_prepare() {
sed -e "s,@HIP_BASE_VERSION_MAJOR@,$(ver_cut 1)," -e "s,@HIP_BASE_VERSION_MINOR@,$(ver_cut 2)," \
-e "s,@HIP_VERSION_PATCH@,$(ver_cut 3)," \
-e "s,@CLANG_PATH@,${LLVM_PREFIX}/bin," -i bin/hipvars.pm || die
+ popd || die
+
+ pushd ${CLR_S} || die
+ eapply "${FILESDIR}/rocclr-${PV}-fix-include.patch"
}
src_configure() {