summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hxd/hxd-0.70.02-r2.ebuild')
-rw-r--r--dev-util/hxd/hxd-0.70.02-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/hxd/hxd-0.70.02-r2.ebuild b/dev-util/hxd/hxd-0.70.02-r2.ebuild
new file mode 100644
index 000000000000..ad8dc60558e7
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-prll-flags.patch
+ "${FILESDIR}"/${P}-llong-redef.patch
+)
+
+DOCS=( README TODO )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}" "un${PN}"
+ doman "${PN}.1" "un${PN}.1"
+ einstalldocs
+}