summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/intel-graphics-system-controller')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index fcad4c9eaa93..7f95472d36d4 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1 +1,2 @@
DIST intel-graphics-system-controller-0.8.7.tar.gz 181536 BLAKE2B 663ec335acdf96edd0c084d2c703687925233caa602e30ac1b189342d1e2a2d370975933fc34171703d3161b4c0f1637bb735fdc89bcd7ed6e5a41b49f946271 SHA512 cc0eabb67fed0c40ab1b0f9501bba87b56c1e97e66242df360036256a18d26912525e78e339c6d09c8d9cf557d00aac60cfb354961304ca41e746f4964705900
+DIST intel-graphics-system-controller-0.8.9.tar.gz 187575 BLAKE2B d4b1a95355e4effe09750cf21133641bd711ac8cdd72c4aba7cde8500ef5221012e20d0dbd7f6ac80e84efea58fe36c72a3c7bf967a9fb21504de9e5bad1752d SHA512 649764594f5043ae148949d2804308884bd93bbac83b3a2066339a0bfed64d4f7bca6a84d480fed0d98677d9fd0746520c8dfbcf03d0714bec2628c7b511bbf7
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild
new file mode 100644
index 000000000000..ff1f3dca0bbb
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND="dev-libs/metee:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}