summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kdevelop/files')
-rw-r--r--dev-util/kdevelop/files/kdevelop-4.5.2-kdevplatform-without-qjson.patch32
-rw-r--r--dev-util/kdevelop/files/kdevelop-4.7.1-gdb.patch30
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/kdevelop/files/kdevelop-4.5.2-kdevplatform-without-qjson.patch b/dev-util/kdevelop/files/kdevelop-4.5.2-kdevplatform-without-qjson.patch
new file mode 100644
index 000000000000..b45623623a23
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-4.5.2-kdevplatform-without-qjson.patch
@@ -0,0 +1,32 @@
+commit fb4234cd72ceebb200bef13234ea9c36c9a62046
+Author: Kevin Funk <kevin@kfunk.org>
+Date: Sun Nov 3 22:09:56 2013 +0100
+
+ Check if kdevplatform has JSON support
+
+ BUG: 327095
+
+diff --git a/languages/cpp/tests/CMakeLists.txt b/languages/cpp/tests/CMakeLists.txt
+index 84ce3ee..fbdd4db 100644
+--- a/languages/cpp/tests/CMakeLists.txt
++++ b/languages/cpp/tests/CMakeLists.txt
+@@ -55,7 +55,9 @@ target_link_libraries(buddiestest
+ ########### next target ###############
+
+ find_package(QJSON)
+-if(QJSON_FOUND)
++# Also check that kdevplatform is built with JSON support
++# see: https://bugs.kde.org/show_bug.cgi?id=327095
++if(QJSON_FOUND AND KDEVPLATFORM_JSONTESTS_LIBRARIES)
+ set(cppfilestest_SRCS test_cppfiles.cpp)
+ kde4_add_unit_test(cppfilestest ${cppfilestest_SRCS})
+ configure_file("testfilepaths.h.cmake" "testfilepaths.h" ESCAPE_QUOTES)
+@@ -67,7 +69,7 @@ if(QJSON_FOUND)
+ ${KDEVPLATFORM_JSONTESTS_LIBRARIES}
+ kdev4cppduchain
+ )
+-endif(QJSON_FOUND)
++endif()
+
+ ########### next target ###############
+
diff --git a/dev-util/kdevelop/files/kdevelop-4.7.1-gdb.patch b/dev-util/kdevelop/files/kdevelop-4.7.1-gdb.patch
new file mode 100644
index 000000000000..4643310bfffc
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-4.7.1-gdb.patch
@@ -0,0 +1,30 @@
+From 633b49c4bd7e434185c69a3dea1841755b75dcba Mon Sep 17 00:00:00 2001
+From: Fernando Rodriguez <frodriguez.developer@outlook.com>
+Date: Sun, 2 Aug 2015 16:20:37 +0200
+Subject: [PATCH] Set the replyReceived flag only if the current command is
+ exec-run.
+
+Fixes various MI errors in remote debugging scenarios.
+
+BUG: 346827
+---
+ debuggers/gdb/gdb.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/debuggers/gdb/gdb.cpp b/debuggers/gdb/gdb.cpp
+index 4642087..df9f3b0 100644
+--- a/debuggers/gdb/gdb.cpp
++++ b/debuggers/gdb/gdb.cpp
+@@ -255,7 +255,8 @@ void GDB::processLine(const QByteArray& line)
+ emit internalCommandOutput(QString::fromUtf8(line) + '\n');
+
+ if (result.reason == "thread-group-started") {
+- receivedReply_ = true;
++ if (currentCmd_->cmdToSend().contains("exec-run"))
++ receivedReply_ = true;
+ // (gdb) -exec-run
+ // =thread-group-started,id="i1",pid="16768"
+ if (line.contains("pid=\"")) {
+--
+2.4.6
+