summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lcov/lcov-1.16-r1.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.16-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-1.16-r1.ebuild b/dev-util/lcov/lcov-1.16-r1.ebuild
new file mode 100644
index 000000000000..11ab700358b7
--- /dev/null
+++ b/dev-util/lcov/lcov-1.16-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
+fi
+
+inherit optfeature prefix
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="https://github.com/linux-test-project/lcov"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/JSON
+ dev-perl/PerlIO-gzip
+"
+
+src_prepare() {
+ default
+ if use prefix; then
+ hprefixify bin/*.{pl,sh}
+ fi
+}
+
+src_compile() { :; }
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ CFG_DIR="${EPREFIX}/etc" \
+ PREFIX="${EPREFIX}/usr" \
+ LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
+ install
+}
+
+pkg_postinst() {
+ optfeature "png output support" dev-perl/GD[png]
+}