summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lcov/lcov-9999.ebuild')
-rw-r--r--dev-util/lcov/lcov-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-util/lcov/lcov-9999.ebuild b/dev-util/lcov/lcov-9999.ebuild
index ce1d928ca92f..aaf34d6df283 100644
--- a/dev-util/lcov/lcov-9999.ebuild
+++ b/dev-util/lcov/lcov-9999.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
inherit git-r3
else
- SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
+ SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
fi
inherit optfeature prefix
DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
+HOMEPAGE="https://github.com/linux-test-project/lcov"
LICENSE="GPL-2+"
SLOT="0"
@@ -34,8 +34,16 @@ src_prepare() {
src_compile() { :; }
+src_test() {
+ emake -j1 check
+}
+
src_install() {
- emake -j1 PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+ emake -j1 \
+ PREFIX="${ED}/usr" \
+ CFG_DIR="${ED}/etc" \
+ LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
+ install
}
pkg_postinst() {