summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lockrun')
-rw-r--r--dev-util/lockrun/Manifest1
-rw-r--r--dev-util/lockrun/lockrun-20120508-r2.ebuild (renamed from dev-util/lockrun/lockrun-20120508-r1.ebuild)9
-rw-r--r--dev-util/lockrun/lockrun-20240415.ebuild37
-rw-r--r--dev-util/lockrun/metadata.xml11
4 files changed, 51 insertions, 7 deletions
diff --git a/dev-util/lockrun/Manifest b/dev-util/lockrun/Manifest
new file mode 100644
index 000000000000..149f25ccb52f
--- /dev/null
+++ b/dev-util/lockrun/Manifest
@@ -0,0 +1 @@
+DIST lockrun-20240415.c.gz 4150 BLAKE2B c70bf08859bf7e2026702b2adc0d3a4224f5a62d25ebeb12359ba34f120300bb7bb1b93a6412696bbf0c0b2f50a958f25beb10a43d45f1dccd148c314fa452eb SHA512 3c7af9bba00018d6ca47c9b737028fb01bd9b7fdd3f29cec89a7c3451eb35fda3bf00f4fe6df8f64b8dcbb2d92f2b7647406bb805dfa3ac78e0ecaf94e95ef05
diff --git a/dev-util/lockrun/lockrun-20120508-r1.ebuild b/dev-util/lockrun/lockrun-20120508-r2.ebuild
index 33e668a9dea2..c418f6128b50 100644
--- a/dev-util/lockrun/lockrun-20120508-r1.ebuild
+++ b/dev-util/lockrun/lockrun-20120508-r2.ebuild
@@ -1,26 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ~hppa x86"
-S="${WORKDIR}"
-
src_unpack() {
cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
}
src_compile() {
- emake CC=$(tc-getCC) ${PN}
+ emake CC="$(tc-getCC)" ${PN}
sed -i README -e '60q;s|^ \*||g' || die
}
diff --git a/dev-util/lockrun/lockrun-20240415.ebuild b/dev-util/lockrun/lockrun-20240415.ebuild
new file mode 100644
index 000000000000..4c6a71c8ec22
--- /dev/null
+++ b/dev-util/lockrun/lockrun-20240415.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+
+SRC_URI="https://downloads.uls.co.za/gentoo/lockrun/lockrun-${PV}.c.gz"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+src_prepare() {
+ default
+ mv "${P}.c" "${PN}.c" || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" ${PN}
+
+ # The below tries to extract the first comment block from the source code
+ # which represents the official "readme" from the project. Delete first
+ # three lines, then everything from (including) the first comment close at
+ # the beginning of a line before removing ' *' from the beginning of the
+ # remaining lines.
+ sed '1,3 d; /^[[:space:]]*[*]\//,$ d; s/^ \*//' "${PN}.c" > README || die
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}
diff --git a/dev-util/lockrun/metadata.xml b/dev-util/lockrun/metadata.xml
index 6f49eba8f496..6aebbc46f559 100644
--- a/dev-util/lockrun/metadata.xml
+++ b/dev-util/lockrun/metadata.xml
@@ -1,5 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>jaco@uls.co.za</email>
+ <name>Jaco Kroon</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>