summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-tools/lttng-tools-2.10.9.ebuild')
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.10.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild b/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild
new file mode 100644
index 000000000000..671fae563392
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.10.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu:=
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( dev-util/lttng-ust:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is -lt 2 6 27; then
+ ewarn "${PN} require Linux kernel >= 2.6.27"
+ ewarn " pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
+ ewarn " the session daemon. There were introduce in the 2.6.27"
+ fi
+}
+
+src_configure() {
+ econf \
+ $(usex ust "" --without-lttng-ust) \
+ --docdir=/usr/share/doc/${PF}
+}