summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.13.5.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.13.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.13.5.ebuild b/dev-util/lttng-ust/lttng-ust-2.13.5.ebuild
new file mode 100644
index 000000000000..70f27a621cfa
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.13.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+IUSE="examples numa"
+
+DEPEND="
+ dev-libs/userspace-rcu:=
+ numa? ( sys-process/numactl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable numa)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}