summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ostree/files')
-rw-r--r--dev-util/ostree/files/ostree-2022.6-musl-allperms.patch17
-rw-r--r--dev-util/ostree/files/ostree-2023.3-dont-force-clang-introspection.patch14
-rw-r--r--dev-util/ostree/files/ostree-2023.3-libgpg-error-underlinked-lld.patch27
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/ostree/files/ostree-2022.6-musl-allperms.patch b/dev-util/ostree/files/ostree-2022.6-musl-allperms.patch
new file mode 100644
index 000000000000..9f4f2a21eb14
--- /dev/null
+++ b/dev-util/ostree/files/ostree-2022.6-musl-allperms.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/879321
+
+From: ernsteiswuerfel <erhard_f@mailbox.org>
+
+--- a/src/libostree/ostree-repo-checkout.c
++++ b/src/libostree/ostree-repo-checkout.c
+@@ -37,6 +37,10 @@
+
+ #define OVERLAYFS_WHITEOUT_PREFIX ".ostree-wh."
+
++#if !defined(ALLPERMS)
++# define ALLPERMS (S_ISUID|S_ISGID|S_ISVTX|S_IRWXU|S_IRWXG|S_IRWXO) /* 07777 */
++#endif
++
+ /* Per-checkout call state/caching */
+ typedef struct {
+ GString *path_buf; /* buffer for real path if filtering enabled */
diff --git a/dev-util/ostree/files/ostree-2023.3-dont-force-clang-introspection.patch b/dev-util/ostree/files/ostree-2023.3-dont-force-clang-introspection.patch
new file mode 100644
index 000000000000..c8f554ae69a0
--- /dev/null
+++ b/dev-util/ostree/files/ostree-2023.3-dont-force-clang-introspection.patch
@@ -0,0 +1,14 @@
+Clang has supported -fstack-clash-protection for a while now.
+--- a/Makefile-libostree.am
++++ b/Makefile-libostree.am
+@@ -266,10 +266,6 @@ libostree_1_la_CFLAGS += $(OT_DEP_LIBSODIUM_CFLAGS)
+ libostree_1_la_LIBADD += $(OT_DEP_LIBSODIUM_LIBS)
+ endif # USE_LIBSODIUM
+
+-# XXX: work around clang being passed -fstack-clash-protection which it doesn't understand
+-# See: https://bugzilla.redhat.com/show_bug.cgi?id=1672012
+-INTROSPECTION_SCANNER_ENV = CC=gcc
+-
+ if BUILDOPT_INTROSPECTION
+ OSTree-1.0.gir: libostree-1.la Makefile
+ OSTree_1_0_gir_EXPORT_PACKAGES = ostree-1
diff --git a/dev-util/ostree/files/ostree-2023.3-libgpg-error-underlinked-lld.patch b/dev-util/ostree/files/ostree-2023.3-libgpg-error-underlinked-lld.patch
new file mode 100644
index 000000000000..f96cb83a1e74
--- /dev/null
+++ b/dev-util/ostree/files/ostree-2023.3-libgpg-error-underlinked-lld.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/905623
+https://github.com/ostreedev/ostree/pull/2880
+
+From c3bd439d3e9c8cfad40a8080d35c5d6b29041039 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 12 Jun 2023 14:04:44 -0700
+Subject: [PATCH] libostree: Link with libgpg-error for gpg_strerror_r API
+
+With f461c02bb55bf2853a3b81ed5c8618040ab54e98 use of gpg_strerror_r
+was added this symbol comes from libgpg-error however, therefore its
+needed to add -lgpg-error to cmdline to resolve this symbol especially
+with gold and lld linker. Fixes
+
+aarch64-yoe-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: gpg_strerror_r
+>>> referenced by ./.libs/libostree-1.so
+--- a/configure.ac
++++ b/configure.ac
+@@ -243,8 +243,7 @@ AC_ARG_WITH(gpgme,
+ [], [with_gpgme=yes])
+ AS_IF([test x$with_gpgme != xno], [
+ have_gpgme=yes
+- PKG_CHECK_MODULES([OT_DEP_GPGME], gpgme >= $LIBGPGME_DEPENDENCY, [], have_gpgme=no)
+- PKG_CHECK_MODULES([OT_DEP_GPG_ERROR], [gpg-error], [], have_gpgme=no)
++ PKG_CHECK_MODULES([OT_DEP_GPGME], [gpgme >= $LIBGPGME_DEPENDENCY gpg-error], [have_gpgme=yes], [have_gpgme=no])
+ ]
+ )
+ AS_IF([test x$with_gpgme != xno && test x$have_gpgme != xyes], [