summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf/patchelf-0.17.0.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.17.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.17.0.ebuild b/dev-util/patchelf/patchelf-0.17.0.ebuild
new file mode 100644
index 000000000000..45b8be95445b
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}