summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/Manifest4
-rw-r--r--dev-util/patchelf/files/patchelf-0.18.0-alpha.patch29
-rw-r--r--dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch9
-rw-r--r--dev-util/patchelf/metadata.xml3
-rw-r--r--dev-util/patchelf/patchelf-0.17.2.ebuild (renamed from dev-util/patchelf/patchelf-0.14.5.ebuild)4
-rw-r--r--dev-util/patchelf/patchelf-0.18.0.ebuild (renamed from dev-util/patchelf/patchelf-0.15.0.ebuild)11
6 files changed, 53 insertions, 7 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 6709bd2b29ca..ed30350914d1 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,2 +1,2 @@
-DIST patchelf-0.14.5.tar.gz 124767 BLAKE2B f2e02fb468db7c8c0c4270c7f95ea6c8dc6ffab7ddb0a6479bd5d1dd0481cbc55982af21a13f42076504417264a11e74d50a9f15d3d5735e47019001abf33e41 SHA512 1b7eca84f6fe2d6f6d4469ca1ccdf35dc920d2052ba94b7daeba6c8cb41fdaff20b1e5bac7c8a7650ff12bf4156da87f84d32e75b09958636dc992a1b7b1a59d
-DIST patchelf-0.15.0.tar.gz 125803 BLAKE2B 08fc2cffd7d9e835c01c828c16762fb0b3c3e422990f2d0028a65a3e0ec849d01bdef699b6f68afa6bf307e34f5e76121fc94460793c95c055552e1d8a68d772 SHA512 3b2d3d6458be5b2d43cd2878dfb1a185a95cc13cd4c94abd0ee79979afb36f46e347acc292b8d9c2954a342b7291774e6a1b63930e9f90a1cf4179ec075ab046
+DIST patchelf-0.17.2.tar.gz 143954 BLAKE2B 7ed684c63955a0b9cfe293fb966f7f08a90c76e8efb2b493eaf3705c57767b31b31e48ab59f39ff1d91b7a4501e6d203e32a40040625a44a7d44113b1320530c SHA512 e5545416d32248d023759457d0a5cd4841d69f39366eb0aa9cfd8a43d2ce372c6e05995bf60ba62bd85c6d98fdece2dbd1e20872e338ef5ac75f11b82ae091b3
+DIST patchelf-0.18.0.tar.gz 331312 BLAKE2B e6ce4ec3bd89c280bb37230dbeb566b803f09900006e79f7dba74f138f66e17746d331baea4def6a43163024b3d86aa8dbac9b2c6545ac146298a8b84373d03b SHA512 6a917d7336b1e8c59f42d4cd1dc725df1378d77657fce13cb31547da1d4805b9df8a834a7b8408fda8aa1dbeb37d0cdca74d8698844ea2f44149f800b802dea6
diff --git a/dev-util/patchelf/files/patchelf-0.18.0-alpha.patch b/dev-util/patchelf/files/patchelf-0.18.0-alpha.patch
new file mode 100644
index 000000000000..c546a4dc2e9b
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-0.18.0-alpha.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/909738
+https://github.com/NixOS/patchelf/pull/529
+Note this has removed the unit test changes because it involves adding a binary
+file which is not supported in portage for now, see
+https://bugs.gentoo.org/835964
+
+commit dbc9aeaadfd982b2d8a04eb74cbcecb83208844d
+Author: matoro <matoro@users.noreply.github.com>
+Date: Sat Nov 4 20:01:22 2023 -0400
+
+ Fix page size on Alpha
+
+ All tests pass.
+
+ Also explicitly specifies -no-pie for executables which should have it
+ disabled, to be compatible with gccs built with --enable-default-pie.
+
+diff --git a/src/patchelf.cc b/src/patchelf.cc
+index b42111d..b4d4a7d 100644
+--- a/src/patchelf.cc
++++ b/src/patchelf.cc
+@@ -367,6 +367,7 @@ unsigned int ElfFile<ElfFileParamNames>::getPageSize() const noexcept
+ // requirements. There is no authoritative list of these values. The
+ // current list is extracted from GNU gold's source code (abi_pagesize).
+ switch (rdi(hdr()->e_machine)) {
++ case EM_ALPHA:
+ case EM_IA_64:
+ case EM_MIPS:
+ case EM_PPC:
diff --git a/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch b/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch
new file mode 100644
index 000000000000..fd92c803ac7c
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-glibc-dt-mips-xhash.patch
@@ -0,0 +1,9 @@
+Add define for DT_MIPS_XHASH (MIPS gnu hash support) using system elf.h header.
+Bug: https://bugs.gentoo.org/860888
+--- /dev/null
++++ b/src/elf.h
+@@ -0,0 +1,4 @@
++#include_next <elf.h>
++#ifndef DT_MIPS_XHASH
++#define DT_MIPS_XHASH 0x70000036
++#endif
diff --git a/dev-util/patchelf/metadata.xml b/dev-util/patchelf/metadata.xml
index 435c7a87acdc..8a3287a04a43 100644
--- a/dev-util/patchelf/metadata.xml
+++ b/dev-util/patchelf/metadata.xml
@@ -4,4 +4,7 @@
<maintainer type="person">
<email>chewi@gentoo.org</email>
</maintainer>
+ <upstream>
+ <remote-id type="github">NixOS/patchelf</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/patchelf/patchelf-0.14.5.ebuild b/dev-util/patchelf/patchelf-0.17.2.ebuild
index 03f3d1f7fb6e..968fd2dbe7bd 100644
--- a/dev-util/patchelf/patchelf-0.14.5.ebuild
+++ b/dev-util/patchelf/patchelf-0.17.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executa
HOMEPAGE="https://github.com/NixOS/patchelf"
SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
-KEYWORDS="amd64 arm64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
LICENSE="GPL-3"
src_prepare() {
diff --git a/dev-util/patchelf/patchelf-0.15.0.ebuild b/dev-util/patchelf/patchelf-0.18.0.ebuild
index da2daad848f7..9999048b656b 100644
--- a/dev-util/patchelf/patchelf-0.15.0.ebuild
+++ b/dev-util/patchelf/patchelf-0.18.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,12 +9,17 @@ DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executa
HOMEPAGE="https://github.com/NixOS/patchelf"
SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~riscv-linux ~x86-linux"
LICENSE="GPL-3"
+PATCHES=(
+ "${FILESDIR}"/${PN}-glibc-dt-mips-xhash.patch
+ "${FILESDIR}"/${PN}-0.18.0-alpha.patch
+)
+
src_prepare() {
- default
rm src/elf.h || die
+ default
sed -i \
-e 's:-Werror::g' \