summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchutils/patchutils-0.3.3.ebuild')
-rw-r--r--dev-util/patchutils/patchutils-0.3.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/patchutils/patchutils-0.3.3.ebuild b/dev-util/patchutils/patchutils-0.3.3.ebuild
new file mode 100644
index 000000000000..36a18d6d968b
--- /dev/null
+++ b/dev-util/patchutils/patchutils-0.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A collection of tools that operate on patch files"
+HOMEPAGE="http://cyberelk.net/tim/patchutils/"
+SRC_URI="http://cyberelk.net/tim/data/patchutils/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# The testsuite makes use of gendiff(1) that comes from rpm, thus if
+# the user wants to run tests, it should install that too.
+DEPEND="test? ( app-arch/rpm )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}