summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgdev/pkgdev-9999.ebuild')
-rw-r--r--dev-util/pkgdev/pkgdev-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/pkgdev/pkgdev-9999.ebuild b/dev-util/pkgdev/pkgdev-9999.ebuild
index 0599a544b7a9..f42159a4c268 100644
--- a/dev-util/pkgdev/pkgdev-9999.ebuild
+++ b/dev-util/pkgdev/pkgdev-9999.ebuild
@@ -8,8 +8,6 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
- PKGDEV_DOCS_PREBUILT=0
-
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
https://github.com/pkgcore/pkgdev.git"
inherit git-r3
@@ -49,7 +47,9 @@ distutils_enable_sphinx doc
distutils_enable_tests setup.py
python_compile_all() {
- use doc && emake -C doc man
+ if use doc; then
+ "${EPYTHON}" setup.py build_man -f || die
+ fi
# HTML pages only
sphinx_compile_all
@@ -58,7 +58,7 @@ python_compile_all() {
python_install_all() {
# If USE=doc, there'll be newly generated docs which we install instead.
if use doc; then
- doman doc/_build/man/*
+ doman build/sphinx/man/*
elif [[ ${PV} != *9999 ]]; then
doman man/*.[0-8]
fi