summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/qdevicemonitor')
-rw-r--r--dev-util/qdevicemonitor/Manifest1
-rw-r--r--dev-util/qdevicemonitor/metadata.xml16
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild47
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild47
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/Manifest b/dev-util/qdevicemonitor/Manifest
new file mode 100644
index 000000000000..da1af57ab4b4
--- /dev/null
+++ b/dev-util/qdevicemonitor/Manifest
@@ -0,0 +1 @@
+DIST qdevicemonitor-1.0.1.tar.gz 955052 SHA256 33bd193dd6ad492973ec1fd0c6076bf3c3e9b90deb04f9c39c3f15095d98712b SHA512 c393d8e33aa6234c2b62af8c25e5fc2e6ccacf9734b77500a512fbd584ecde723b9d5717dbe268d65565d3d30801d297236b3546263ba2689ba246d2b13b8f55 WHIRLPOOL 0b1a1f24ea21897adcf24e5a3ff3dcb42244052c6cf28d6898791c50c250376f98b82496d680c5693bbc680eff8f826134de666e5226c1226ed2e8927d1b13ee
diff --git a/dev-util/qdevicemonitor/metadata.xml b/dev-util/qdevicemonitor/metadata.xml
new file mode 100644
index 000000000000..5351b1543c26
--- /dev/null
+++ b/dev-util/qdevicemonitor/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alopatindev@gmail.com</email>
+ <name>Alexander Lopatin</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alopatindev/qdevicemonitor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild
new file mode 100644
index 000000000000..eb497b2dae79
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="6"
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/alopatindev/qdevicemonitor"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
new file mode 100644
index 000000000000..eb497b2dae79
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="6"
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/alopatindev/qdevicemonitor"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}