summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/redo/redo-99999.ebuild')
-rw-r--r--dev-util/redo/redo-99999.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-util/redo/redo-99999.ebuild b/dev-util/redo/redo-99999.ebuild
deleted file mode 100644
index eb551f91c49d..000000000000
--- a/dev-util/redo/redo-99999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2018-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="sqlite"
-inherit git-r3 multilib multiprocessing python-utils-r1 python-single-r1
-
-DESCRIPTION="Smaller, easier, more powerful, and more reliable than make"
-HOMEPAGE="https://github.com/apenwarr/redo"
-EGIT_REPO_URI="https://github.com/apenwarr/redo"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/beautifulsoup[${PYTHON_MULTI_USEDEP}]
- dev-python/markdown[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
-"
-RDEPEND="
- ${BDEPEND}
-"
-
-src_configure() {
- echo ${PYTHON} > redo/whichpython || die
-}
-
-src_compile() {
- ./do -j$(makeopts_jobs) build || die
-}
-
-src_test() {
- local ARCH= CFLAGS= CXXFLAGS= LDFLAGS=
- ./do -j$(makeopts_jobs) test || die
-}
-
-src_install() {
- DESTDIR="${D}" \
- DOCDIR="${D}/usr/share/doc/${PF}" \
- LIBDIR="${D}/$(python_get_sitedir)/${PN}" \
- ./do -j$(makeopts_jobs) \
- install || die
-
- python_fix_shebang "${D}"
-
- sed -i \
- -e 's|/lib/|/'"$(get_libdir)"'/|g' \
- "${D}"/usr/bin/* || die
-
- python_optimize
-}