summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rizin')
-rw-r--r--dev-util/rizin/Manifest2
-rw-r--r--dev-util/rizin/rizin-0.4.1.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index 4904a831c03e..de010726dcf3 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,2 +1,4 @@
DIST rizin-src-v0.4.0.tar.xz 11432232 BLAKE2B 095ca9d317296afca9514a70f208e9aa87fc426e6b7e41163f64d5a1192a4d9ccd8ece9c4f13a24fc973668dece625fa13ad75542695a66c542fe2f0d9e66733 SHA512 9d576bee48e5ceae46b4e309c53e01b82edf89a95046f576e1c38fefa73353d6d1f04e6d444332324387d4e115bc87659a358629f7277a41dfef44c82364547b
+DIST rizin-src-v0.4.1.tar.xz 11453808 BLAKE2B dcae21320e2533904d9a337d4fb9cc9a450439753106dc5c341e3ca7c788f0a44034340eb0dfe3fad4f1d8a7ebe873720d42d70ce343e8c7b953d4d148a38da2 SHA512 565358e11fd4db44ec7f8c25313a1cfc726c38a17afcb699c3fc2af520242fb343ea4a267f0a8e35bdc08e9a765a6a17ec7b8eaba9f9ad9ef5a7dcfe01c7354c
DIST rizin-testbins-64a6f26369bf5893ecc20cb8984a5ad506ef8566.tar.gz 172591261 BLAKE2B e78843fd95ac0406f66490b7253206e77787fc65780bc7c6a67d26aa9618a6f85803a88724ad424a7bdeeb20d95ebf9314e582029ac778d7d4de4f207ff54aad SHA512 ada4a3faad94553f0f2802419ba604177bb66d332b1a351effd485d65bd8365abb36d736486bbd0bcbc0da584ad4a2edaa7aa3cb62fa12811282c2e0afecb950
+DIST rizin-testbins-aef7f7b714a696f382f55b8cbbf94c5b69518de3.tar.gz 178497762 BLAKE2B 8c82a537a58e65d35bd8b309311c4377b5996ff4b650fc6cff4cf347e04fbe4b2ec0e88f03ff43572c8e99675186b05b393b7da070a60ab107c3cca829d2544b SHA512 2745b58646963c28a45b46e8e709845c355863e61cf796aeb3d2e617f1bf2f9916a4b106cd08f48b1ef6e36f7f38624b5977dcd62c921124b0a1122b7220baa8
diff --git a/dev-util/rizin/rizin-0.4.1.ebuild b/dev-util/rizin/rizin-0.4.1.ebuild
new file mode 100644
index 000000000000..1fcd320b67bf
--- /dev/null
+++ b/dev-util/rizin/rizin-0.4.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# This is the commit that the CI for the release commit used
+BINS_COMMIT="aef7f7b714a696f382f55b8cbbf94c5b69518de3"
+
+inherit meson python-any-r1
+
+DESCRIPTION="reverse engineering framework for binary analysis"
+HOMEPAGE="https://rizin.re/"
+
+SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
+ test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
+KEYWORDS="amd64 ~arm64 ~x86"
+
+LICENSE="Apache-2.0 BSD LGPL-3 MIT"
+SLOT="0/${PV}"
+IUSE="test"
+
+# Need to audit licenses of the binaries used for testing
+RESTRICT="fetch !test? ( test )"
+
+RDEPEND="
+ sys-apps/file
+ app-arch/lz4:0=
+ dev-libs/capstone:0=
+ dev-libs/libuv:0=
+ dev-libs/libzip:0=
+ dev-libs/openssl:0=
+ >=dev-libs/tree-sitter-0.19.0
+ dev-libs/xxhash
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-never-rebuild-parser.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+
+ local py_to_mangle=(
+ librz/core/cmd_descs/cmd_descs_generate.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/GetLz4LibraryVersion.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/InstallSymlink.py
+ subprojects/lz4-1.9.3/tests/test-lz4-list.py
+ subprojects/lz4-1.9.3/tests/test-lz4-speed.py
+ subprojects/lz4-1.9.3/tests/test-lz4-versions.py
+ sys/clang-format.py
+ test/fuzz/scripts/fuzz_rz_asm.py
+ test/scripts/gdbserver.py
+ )
+
+ python_fix_shebang "${py_to_mangle[@]}"
+
+ if use test; then
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcli=enabled
+ -Duse_sys_capstone=enabled
+ -Duse_sys_magic=enabled
+ -Duse_sys_libzip=enabled
+ -Duse_sys_zlib=enabled
+ -Duse_sys_lz4=enabled
+ -Duse_sys_xxhash=enabled
+ -Duse_sys_openssl=enabled
+ -Duse_sys_tree_sitter=enabled
+
+ $(meson_use test enable_tests)
+ $(meson_use test enable_rz_test)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We can select running either unit or integration tests, or all of
+ # them by not passing --suite. According to upstream, integration
+ # tests are more fragile and unit tests are sufficient for testing
+ # packaging, so only run those.
+ meson_src_test --suite unit
+}