summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocminfo/rocminfo-3.7.0.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-3.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-3.7.0.ebuild b/dev-util/rocminfo/rocminfo-3.7.0.ebuild
new file mode 100644
index 000000000000..c993e808caf5
--- /dev/null
+++ b/dev-util/rocminfo/rocminfo-3.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocminfo-rocm-${PV}"
+fi
+
+DESCRIPTION="ROCm Application for Reporting System Info"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-libs/rocr-runtime"
+DEPEND="${RDEPEND}"