summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rr/rr-4.5.0.ebuild')
-rw-r--r--dev-util/rr/rr-4.5.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/rr/rr-4.5.0.ebuild b/dev-util/rr/rr-4.5.0.ebuild
index 09413354976f..4ad1d8612c20 100644
--- a/dev-util/rr/rr-4.5.0.ebuild
+++ b/dev-util/rr/rr-4.5.0.ebuild
@@ -7,7 +7,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
CMAKE_BUILD_TYPE=Release
-inherit cmake-utils python-single-r1
+inherit cmake-utils linux-info python-single-r1
DESCRIPTION="Record and Replay Framework"
HOMEPAGE="http://rr-project.org/"
@@ -28,5 +28,9 @@ RDEPEND="
${DEPEND}"
pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="SECCOMP"
+ linux-info_pkg_setup
+ fi
python-single-r1_pkg_setup
}