summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rr/rr-5.0.0.ebuild')
-rw-r--r--dev-util/rr/rr-5.0.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-util/rr/rr-5.0.0.ebuild b/dev-util/rr/rr-5.0.0.ebuild
deleted file mode 100644
index 19ae612d07d5..000000000000
--- a/dev-util/rr/rr-5.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-CMAKE_BUILD_TYPE=Release
-
-inherit cmake-utils linux-info python-single-r1
-
-DESCRIPTION="Record and Replay Framework"
-HOMEPAGE="https://rr-project.org/"
-SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.tar.gz"
-
-LICENSE="MIT BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- sys-libs/zlib
- dev-libs/capnproto
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- sys-devel/gdb[xml]"
-# Add all the deps needed only at build/test time.
-DEPEND+="
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- sys-devel/gdb[xml]
- )"
-
-RESTRICT="!test? ( test )"
-
-#PATCHES=(
-# "${FILESDIR}"/${P}-sysmacros.patch
-#)
-
-pkg_setup() {
- if use kernel_linux; then
- CONFIG_CHECK="SECCOMP"
- linux-info_pkg_setup
- fi
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i 's:-Werror::' CMakeLists.txt || die #609192
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake-utils_src_configure
-}