summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scanmem/scanmem-0.17.ebuild')
-rw-r--r--dev-util/scanmem/scanmem-0.17.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/scanmem/scanmem-0.17.ebuild b/dev-util/scanmem/scanmem-0.17.ebuild
new file mode 100644
index 000000000000..542361fbb188
--- /dev/null
+++ b/dev-util/scanmem/scanmem-0.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Locate and modify variables in executing processes"
+HOMEPAGE="https://github.com/scanmem/scanmem"
+SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui static-libs"
+
+DEPEND="sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ gui? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3
+ sys-auth/polkit
+ )"
+
+REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use gui && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ sed -i "/CFLAGS/d" Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-readline
+ $(use_enable gui)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use gui ; then
+ docinto gui
+ dodoc gui/{README,TODO}
+ python_fix_shebang "${ED}"
+ fi
+ find "${ED}" -type f -name "*.la" -delete || die
+}