summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sel/sel-0.08.4-r2.ebuild')
-rw-r--r--dev-util/sel/sel-0.08.4-r2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-util/sel/sel-0.08.4-r2.ebuild b/dev-util/sel/sel-0.08.4-r2.ebuild
index 6c4bae9142a8..08560fb423e2 100644
--- a/dev-util/sel/sel-0.08.4-r2.ebuild
+++ b/dev-util/sel/sel-0.08.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -11,9 +11,11 @@ HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="amd64 ppc s390 sparc x86"
+KEYWORDS="amd64 ppc ~s390 sparc x86"
RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( "help.txt" README.GER whatsnew )
@@ -25,7 +27,8 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+ local PKGCONFIG="$(tc-getPKG_CONFIG)"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="$(${PKGCONFIG} --libs ncurses)"
}
src_install() {