summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/shflags/shflags-1.2.3.ebuild')
-rw-r--r--dev-util/shflags/shflags-1.2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/shflags/shflags-1.2.3.ebuild b/dev-util/shflags/shflags-1.2.3.ebuild
new file mode 100644
index 000000000000..0466a6600bd6
--- /dev/null
+++ b/dev-util/shflags/shflags-1.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line flags module for Unix shell scripts"
+HOMEPAGE="https://github.com/kward/shflags"
+SRC_URI="https://github.com/kward/shflags/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
+
+src_test() {
+ sh test_runner || die
+}
+
+src_install() {
+ dodoc README* doc/*.txt
+ insinto /usr/share/misc
+ doins "${PN}"
+ use examples && dodoc examples/*
+}