summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/spirv-tools/spirv-tools-99999999.ebuild')
-rw-r--r--dev-util/spirv-tools/spirv-tools-99999999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/spirv-tools/spirv-tools-99999999.ebuild b/dev-util/spirv-tools/spirv-tools-99999999.ebuild
new file mode 100644
index 000000000000..fa22fe6b2b6d
--- /dev/null
+++ b/dev-util/spirv-tools/spirv-tools-99999999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=SPIRV-Tools
+CMAKE_ECLASS="cmake"
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="1b35745ad1c9a988bc427b976a9a2fe7afd4dada"
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/${MY_PN}-${EGIT_COMMIT}
+fi
+
+DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
+HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests fail upon finding symbols that do not match a regular expression
+# in the generated library. Easily hit with non-standard compiler flags
+RESTRICT="test"
+COMMON_DEPEND=">=dev-util/spirv-headers-1.5.4.2_pre20210526"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND=""
+BDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+ "-DSPIRV_WERROR=OFF"
+ "-DSPIRV_TOOLS_BUILD_STATIC=OFF"
+ "-DBUILD_SHARED_LIBS=ON"
+ )
+
+ cmake_src_configure
+}