summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/Manifest1
-rw-r--r--dev-util/squashdelta/metadata.xml6
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.1.ebuild6
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.2.ebuild32
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild6
5 files changed, 42 insertions, 9 deletions
diff --git a/dev-util/squashdelta/Manifest b/dev-util/squashdelta/Manifest
index 2eff03e62875..0cdba9408f90 100644
--- a/dev-util/squashdelta/Manifest
+++ b/dev-util/squashdelta/Manifest
@@ -1 +1,2 @@
DIST squashdelta-0.1.1.tar.bz2 78504 BLAKE2B f9aa13b3af35bd97650b31fac718837763b73c2817548a3fde75841993092d717ea78826a3e29d472290d4f9164f8cfcc9f9999613f199c21251080584dbd9f7 SHA512 efe90831e412ed6627d44390054dc89339e85bcd3be452f16fb32d00989bbdc9480dbefcea624941b4866a686a356b0371c33de31903afa70af26eecbe902844
+DIST squashdelta-0.1.2.tar.bz2 79865 BLAKE2B fe375da70e25eaa5b70aa2e231f04b9ce47aa1aaea3872df331065ba8710a0e4ce1ca096715d18e5094f514ce3a8adb9d08109a4894ca75a4b3e5ef083f8e66f SHA512 802a1a6c6e7d117e4fb7f74a8144cc7b8b237e28f2028c72623b99a88b23d857ceb99f2d23653d253af829c3e6b290db98420923d613569cf523c2a7fc600f43
diff --git a/dev-util/squashdelta/metadata.xml b/dev-util/squashdelta/metadata.xml
index ef0fca903aa9..4084bde7d1b1 100644
--- a/dev-util/squashdelta/metadata.xml
+++ b/dev-util/squashdelta/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mgorny@gentoo.org</email>
@@ -10,7 +10,7 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/squashdelta/issues/</bugs-to>
- <remote-id type="github">mgorny/squashdelta</remote-id>
+ <bugs-to>https://github.com/projg2/squashdelta/issues/</bugs-to>
+ <remote-id type="github">projg2/squashdelta</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-util/squashdelta/squashdelta-0.1.1.ebuild b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
index ea0756376a3d..5b2b0afe380c 100644
--- a/dev-util/squashdelta/squashdelta-0.1.1.ebuild
+++ b/dev-util/squashdelta/squashdelta-0.1.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
-HOMEPAGE="https://github.com/mgorny/squashdelta/"
-SRC_URI="https://github.com/mgorny/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
+HOMEPAGE="https://github.com/projg2/squashdelta/"
+SRC_URI="https://github.com/projg2/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
# uses public-domain murmurhash3
LICENSE="BSD public-domain"
diff --git a/dev-util/squashdelta/squashdelta-0.1.2.ebuild b/dev-util/squashdelta/squashdelta-0.1.2.ebuild
new file mode 100644
index 000000000000..5b2b0afe380c
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/projg2/squashdelta/"
+SRC_URI="https://github.com/projg2/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
index af4bc7cf66ba..b1ee7d10f874 100644
--- a/dev-util/squashdelta/squashdelta-9999.ebuild
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+EGIT_REPO_URI="https://github.com/projg2/${PN}.git"
inherit autotools git-r3
DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
-HOMEPAGE="https://github.com/mgorny/squashdelta/"
+HOMEPAGE="https://github.com/projg2/squashdelta/"
SRC_URI=""
# uses public-domain murmurhash3