summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/tea')
-rw-r--r--dev-util/tea/Manifest2
-rw-r--r--dev-util/tea/metadata.xml17
-rw-r--r--dev-util/tea/tea-0.9.2.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/tea/Manifest b/dev-util/tea/Manifest
new file mode 100644
index 000000000000..da03c4ffef55
--- /dev/null
+++ b/dev-util/tea/Manifest
@@ -0,0 +1,2 @@
+DIST tea-0.9.2-deps.tar.xz 56068596 BLAKE2B 0317a92e3879514dc68e5b0abc2aa08b9b940695db05cfa13227d3b0bc2399d1617d7a8f51c2eb60d3e791f42bf9d3b73c5d1360fac8114a11077a30cf837ccc SHA512 2f8cd3da7e89e54ccbf47c7c7e31b18dabd7082bd10f4db42ea7c6bedfe49e0c1c006ee6b03d20026e001800fa9f6a995388ea7aa258956cf41e8071696a9bb4
+DIST tea-0.9.2.tar.gz 709669 BLAKE2B 44e757dffaf1c8d6fe9de5eaefad58f6f19722f39c870da55932a0672c4040ff0e918e82594147361079e75d934cd58995f119c8ec132870e3f6c4ce2a5d016e SHA512 05be2ea5f845773324c10fe8f0340c96f40f392b7ef8cafb44463b7a5492de2216799d8cc339e7dc42e921afcd3ba0e21be133a87385e907af47261733935e62
diff --git a/dev-util/tea/metadata.xml b/dev-util/tea/metadata.xml
new file mode 100644
index 000000000000..0b940028cf9a
--- /dev/null
+++ b/dev-util/tea/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ tea is a productivity helper for Gitea. It can be used to manage most
+ entities on one or multiple Gitea instances and provides local helpers like
+ 'tea pr checkout'.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitea.com/gitea/tea/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/tea/tea-0.9.2.ebuild b/dev-util/tea/tea-0.9.2.ebuild
new file mode 100644
index 000000000000..896625516252
--- /dev/null
+++ b/dev-util/tea/tea-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="Command line tool to interact with Gitea server"
+HOMEPAGE="https://gitea.com/gitea/tea/"
+SRC_URI="
+ https://gitea.com/gitea/tea/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+S="${WORKDIR}/tea"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe tea
+
+ newbashcomp contrib/autocomplete.sh tea
+
+ einstalldocs
+}