summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/treecc')
-rw-r--r--dev-util/treecc/metadata.xml7
-rw-r--r--dev-util/treecc/treecc-0.3.10-r1.ebuild4
-rw-r--r--dev-util/treecc/treecc-0.3.10-r2.ebuild45
3 files changed, 49 insertions, 7 deletions
diff --git a/dev-util/treecc/metadata.xml b/dev-util/treecc/metadata.xml
index c99669dda129..85e4ed814fa2 100644
--- a/dev-util/treecc/metadata.xml
+++ b/dev-util/treecc/metadata.xml
@@ -1,8 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>dotnet@gentoo.org</email>
- <name>Gentoo Dotnet Project</name>
-</maintainer>
+<!-- maintainer-needed -->
</pkgmetadata>
diff --git a/dev-util/treecc/treecc-0.3.10-r1.ebuild b/dev-util/treecc/treecc-0.3.10-r1.ebuild
index b7f084dfe7cc..f18b21d19d6b 100644
--- a/dev-util/treecc/treecc-0.3.10-r1.ebuild
+++ b/dev-util/treecc/treecc-0.3.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc examples"
DEPEND="doc? ( app-text/texi2html )"
diff --git a/dev-util/treecc/treecc-0.3.10-r2.ebuild b/dev-util/treecc/treecc-0.3.10-r2.ebuild
new file mode 100644
index 000000000000..faf9e7ab98ef
--- /dev/null
+++ b/dev-util/treecc/treecc-0.3.10-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compiler-compiler tool for aspect-oriented programming"
+HOMEPAGE="https://www.gnu.org/software/dotgnu/"
+SRC_URI="https://download.savannah.gnu.org/releases/dotgnu-pnet/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-text/texi2html )"
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+
+ if use doc; then
+ [[ -f "${S}"/doc/treecc.texi ]] || die "treecc.texi was not generated"
+ cd "${S}"/doc || die
+ texi2html -split_chapter "${S}"/doc/treecc.texi \
+ || die "texi2html failed"
+ cd "${S}" || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc examples/README
+ dodoc examples/{expr_c.tc,gram_c.y,scan_c.l}
+ fi
+
+ if use doc; then
+ dodoc doc/*.{txt,html}
+ docinto html
+ dodoc -r doc/treecc/*.html
+ fi
+}