summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uftrace')
-rw-r--r--dev-util/uftrace/Manifest1
-rw-r--r--dev-util/uftrace/uftrace-0.9.4-r100.ebuild61
-rw-r--r--dev-util/uftrace/uftrace-0.9.4.ebuild43
3 files changed, 0 insertions, 105 deletions
diff --git a/dev-util/uftrace/Manifest b/dev-util/uftrace/Manifest
index a9e6c5f4a0bc..8348aba2e207 100644
--- a/dev-util/uftrace/Manifest
+++ b/dev-util/uftrace/Manifest
@@ -1,2 +1 @@
DIST uftrace-0.10.tar.gz 1111530 BLAKE2B 29388523e1009276ba4609d85e5979e823d028ff647239aa02ec2cac5ae21c7812c7699d47c09c0b9289a0debb39a2f502615547c8e658a821d5078e3b12c6fe SHA512 788234e4156974a70f06d02527e56e5fac821e8b66363dc5fc55d68797c374043c0b66b18b4ab1488b9647e08969e8dc94a64d6bb1a38ccad4cf98eaecc6e919
-DIST uftrace-0.9.4.tar.gz 1068091 BLAKE2B cbf9ead0e2c0e8d59be379e65617cfa310fd4134cfbbc8091c489913f108e8a7a0b81e33d46032f3717a5bb8127cbeeeb246e3be0c37da03981dac4bacc07119 SHA512 f73ad4461051b9c61668161e077897d118ac556d234ff204e32bf14ecdc2c0df148da30ea5d5054641e79ea20b29261d6f637908f5047f5669207ef244865358
diff --git a/dev-util/uftrace/uftrace-0.9.4-r100.ebuild b/dev-util/uftrace/uftrace-0.9.4-r100.ebuild
deleted file mode 100644
index ce77c3c09d5b..000000000000
--- a/dev-util/uftrace/uftrace-0.9.4-r100.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( luajit )
-
-inherit bash-completion-r1 lua-single
-
-DESCRIPTION="Function (graph) tracer for user-space"
-HOMEPAGE="https://github.com/namhyung/uftrace"
-SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="bash-completion capstone lua"
-
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-RESTRICT="test"
-
-RDEPEND="
- sys-libs/ncurses:=
- virtual/libelf:=
- capstone? ( dev-libs/capstone:0= )
- lua? ( ${LUA_DEPS} )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
-}
-
-src_configure() {
- local myconf=(
- $(use_with capstone)
- --without-libpython
- )
- if use lua && use lua_single_target_luajit; then
- myconf+=(
- --with-libluajit
- )
- else
- myconf+=(
- --without-libluajit
- )
- fi
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- default
- dodoc doc/*.{md,gif,png}
- use bash-completion && newbashcomp misc/bash-completion.sh uftrace
-}
diff --git a/dev-util/uftrace/uftrace-0.9.4.ebuild b/dev-util/uftrace/uftrace-0.9.4.ebuild
deleted file mode 100644
index 51506dbff692..000000000000
--- a/dev-util/uftrace/uftrace-0.9.4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1
-
-DESCRIPTION="Function (graph) tracer for user-space"
-HOMEPAGE="https://github.com/namhyung/uftrace"
-SRC_URI="https://github.com/namhyung/uftrace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="bash-completion capstone luajit"
-
-RESTRICT="test"
-
-RDEPEND="
- sys-libs/ncurses:=
- virtual/libelf:=
- capstone? ( dev-libs/capstone:0= )
- luajit? ( dev-lang/luajit )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- sed -i -e "s/ARCH/MYARCH/g" -e "/ldconfig/d" -e "/bash.completion/d" Makefile || die
-}
-
-src_configure() {
- econf \
- $(use_with capstone) \
- $(use_with luajit libluajit) \
- --without-libpython
-}
-
-src_install() {
- default
- dodoc doc/*.{md,gif,png}
- use bash-completion && newbashcomp misc/bash-completion.sh uftrace
-}