summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/vulkan-headers/vulkan-headers-1.2.143.ebuild')
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-1.2.143.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.2.143.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.2.143.ebuild
new file mode 100644
index 000000000000..10d614b0d1fe
--- /dev/null
+++ b/dev-util/vulkan-headers/vulkan-headers-1.2.143.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Vulkan-Headers
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
+
+DESCRIPTION="Vulkan Header files and API registry"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND=">=dev-util/cmake-3.10.2"