summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitchangelog/Manifest1
-rw-r--r--dev-util/gitchangelog/gitchangelog-3.0.9.ebuild41
-rw-r--r--dev-util/gitchangelog/metadata.xml15
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/gitchangelog/Manifest b/dev-util/gitchangelog/Manifest
new file mode 100644
index 000000000000..cd663768e53e
--- /dev/null
+++ b/dev-util/gitchangelog/Manifest
@@ -0,0 +1 @@
+DIST gitchangelog-3.0.9.tar.gz 52483 BLAKE2B 8e7fc61dee6cba6e630cb2006d5bec988ea3d7a7c1e09789b430e11d4c3d8f5e7ff7ee1231dbbcb56185c84fa9c2bbf6a353980f5a70c8a0cce51b2dce83fb5d SHA512 4e290d75455ddddb7d12d831dce973771f861d23d6b6548b8a9e24e838b0931255dfc8c9ef25765fb4f269d5cdad6bd207fbaa3626a3b24681efdbb56ad9e1b1
diff --git a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
new file mode 100644
index 000000000000..d2e9d691c1bb
--- /dev/null
+++ b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTULS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+DESCRIPTION="Creates a changelog from git log history"
+HOMEPAGE="https://github.com/sarnold/gitchangelog"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/gitchangelog.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/minimock[${PYTHON_USEDEP}] )
+"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pystache[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" -m nose -sx . || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-util/gitchangelog/metadata.xml b/dev-util/gitchangelog/metadata.xml
new file mode 100644
index 000000000000..32c48c0aca94
--- /dev/null
+++ b/dev-util/gitchangelog/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription lang="en">
+ Create a fancy changelog from git log history (in rst or md) and
+ customize your config with Python callables and regex.
+</longdescription>
+<upstream>
+ <remote-id type="github">sarnold/gitchangelog</remote-id>
+</upstream>
+</pkgmetadata>