summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/re2c/Manifest1
-rw-r--r--dev-util/re2c/files/re2c-1.3-lexer-overflow.patch40
-rw-r--r--dev-util/re2c/re2c-1.3-r1.ebuild28
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-util/re2c/Manifest b/dev-util/re2c/Manifest
index 73bb5e2abd53..59708a0ee97f 100644
--- a/dev-util/re2c/Manifest
+++ b/dev-util/re2c/Manifest
@@ -1,2 +1 @@
-DIST re2c-1.3.tar.xz 1239280 BLAKE2B ae2a8fc323408dd31d39c352bd622d89d19178b7993618ea043bbfd32509fb7573d2b5b50663e100d24fc275fa479982cb1f66ed49638edca61f551fb653176d SHA512 c7084ab2399fb6b96cef74c1393715d90830f43b82b96af46feb71ef008c0215381c3dbea0b003ff810d869db6021e28001b9d588ad55c616642244b2da09c0e
DIST re2c-2.0.3.tar.xz 1288996 BLAKE2B 76913a79ad9c237843ccbe86dd05db755da19fc89351b64d6ece6a9a8d53860f1cc12493748fca5b7391cddff4f4668295fb2613c257c128870ea2e7163811ed SHA512 893c533e9847a6236d55ae65e413ddc48b7531b89f5552a3ad79beeac079317ceca4c35710f3c2d88a6de5a3c0a5070a24a8cffb1b4277578a41697ea0e3bf8c
diff --git a/dev-util/re2c/files/re2c-1.3-lexer-overflow.patch b/dev-util/re2c/files/re2c-1.3-lexer-overflow.patch
deleted file mode 100644
index 4222ef430c32..000000000000
--- a/dev-util/re2c/files/re2c-1.3-lexer-overflow.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://bugs.gentoo.org/718350
-
-From c4603ba5ce229db83a2a4fb93e6d4b4e3ec3776a Mon Sep 17 00:00:00 2001
-From: Ulya Trofimovich <skvadrik@gmail.com>
-Date: Fri, 17 Apr 2020 22:47:14 +0100
-Subject: [PATCH] Fix crash in lexer refill (reported by Agostino Sarubbo).
-
-The crash happened in a rare case of a very long lexeme that doen't fit
-into the buffer, forcing buffer reallocation.
-
-The crash was caused by an incorrect calculation of the shift offset
-(it was smaller than necessary). As a consequence, the data from buffer
-start and up to the beginning of the current lexeme was not discarded
-(as it should have been), resulting in less free space for new data than
-expected.
----
- src/parse/scanner.cc | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/src/parse/scanner.cc
-+++ b/src/parse/scanner.cc
-@@ -155,13 +155,14 @@ bool Scanner::fill(size_t need)
- if (!buf) fatal("out of memory");
-
- memmove(buf, tok, copy);
-- shift_ptrs_and_fpos(buf - bot);
-+ shift_ptrs_and_fpos(buf - tok);
- delete [] bot;
- bot = buf;
-
- free = BSIZE - copy;
- }
-
-+ DASSERT(lim + free <= bot + BSIZE);
- if (!read(free)) {
- eof = lim;
- memset(lim, 0, YYMAXFILL);
---
-2.26.1
-
diff --git a/dev-util/re2c/re2c-1.3-r1.ebuild b/dev-util/re2c/re2c-1.3-r1.ebuild
deleted file mode 100644
index d90e052b5214..000000000000
--- a/dev-util/re2c/re2c-1.3-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="tool for generating C-based recognizers from regular expressions"
-HOMEPAGE="http://re2c.org/"
-SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="debug"
-
-PATCHES=("${FILESDIR}"/${P}-lexer-overflow.patch)
-
-src_configure() {
- econf \
- ac_cv_path_BISON="no" \
- $(use_enable debug)
-}
-
-src_install() {
- default
-
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r README.md CHANGELOG examples
-}