summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/Manifest2
-rw-r--r--dev-util/cppcheck/cppcheck-1.88.ebuild115
-rw-r--r--dev-util/cppcheck/cppcheck-2.2.ebuild81
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch17
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch101
5 files changed, 0 insertions, 316 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index c78e131f4306..5de50914c64f 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,3 +1 @@
-DIST cppcheck-1.88.tar.gz 2364053 BLAKE2B b688974ff83019422cc5b2ec575d9838bdff4ada17d71fb3d436f07eea50429490c222659163b845667d98c0ec186b3288464827894e379fd017dd0c3fea645f SHA512 fa4ede0665546341af0ba3dae09a00b6efae09ec7838c616c580be01ff6902594d61168a059539779be0c78e1708d2bd9c8e7987dd0bb67dc8fa332a10d1de6a
-DIST cppcheck-2.2.tar.gz 3561406 BLAKE2B e436de4bec5412a18f013c8557a966c28c14edcd07fbb80eb53a897848d15f32afc180798ea1a074742f896b15d4020755c104b87dc8f82252121b58a92b92dc SHA512 d766187a69d6aa839e072e3c0ed44009621ca8492504257288ca2f49774f705a1ebcf2957f0801ac6eab2ffbdd845e9237f1213f85c6d0fcdbf16b1e7c690327
DIST cppcheck-2.4.1.tar.gz 3761646 BLAKE2B 4c791088621f989e2529c92de38a73676fc3394e8cac72822596f7a75594283d0983693d693aa903a3ffb80bc0e1e20e71b55db5682d4d01c135ed77b2fc2e3c SHA512 8fb1ed5faa0071fc69405b7eb5b41e9f94b77d097158ea0d4f5e4da8a5087b9d1ab7bf37f8dc73d00096d3d2494aeb431af8029f0d4f1e2085f5b9b72bdc2d09
diff --git a/dev-util/cppcheck/cppcheck-1.88.ebuild b/dev-util/cppcheck/cppcheck-1.88.ebuild
deleted file mode 100644
index 09857bcc74b6..000000000000
--- a/dev-util/cppcheck/cppcheck-1.88.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-inherit distutils-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc64 sparc x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.88-tinyxml2.patch
- "${FILESDIR}"/${PN}-1.88-ldflags.patch
-)
-
-src_prepare() {
- default
-
- rm -r externals/tinyxml || die
-}
-
-src_configure() {
- tc-export CXX PKG_CONFIG
- export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
-
- emake dmake
- ./dmake || die
-
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- popd || die
- fi
-}
-
-src_compile() {
- emake ${PN} man \
- CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- emake
- popd || die
- fi
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r tools/triage
-}
diff --git a/dev-util/cppcheck/cppcheck-2.2.ebuild b/dev-util/cppcheck/cppcheck-2.2.ebuild
deleted file mode 100644
index 175f33dd4bce..000000000000
--- a/dev-util/cppcheck/cppcheck-2.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-inherit distutils-r1 toolchain-funcs cmake
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc64 sparc x86"
-IUSE="htmlreport pcre qt5 +z3"
-
-RDEPEND="
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qthelp
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
- z3? ( sci-mathematics/z3 )
-"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure() {
-
- local mycmakeargs=(
- -DHAVE_RULES="$(usex pcre)"
- -DBUILD_GUI="$(usex qt5)"
- -DUSE_Z3="$(usex z3)"
- -DFILESDIR="${EROOT}/usr/share/${PN}/"
- -DENABLE_OSS_FUZZ=OFF
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}" \
- FILESDIR="${EROOT}/usr/share/${PN}/"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin "${WORKDIR}/${P}_build/bin/${PN}-gui"
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
-
- dodoc -r tools/triage
-}
diff --git a/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch b/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch
deleted file mode 100644
index ef7e01212a3f..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/tools/dmake.cpp b/tools/dmake.cpp
-index c3afd26..5c3a0a6 100644
---- a/tools/dmake.cpp
-+++ b/tools/dmake.cpp
-@@ -370,10 +370,10 @@ int main(int argc, char **argv)
- fout << ".PHONY: run-dmake tags\n\n";
- fout << "\n###### Targets\n\n";
- fout << "cppcheck: $(LIBOBJ) $(CLIOBJ) $(EXTOBJ)\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
- fout << "all:\tcppcheck testrunner\n\n";
- fout << "testrunner: $(TESTOBJ) $(LIBOBJ) $(EXTOBJ) cli/threadexecutor.o cli/cmdlineparser.o cli/cppcheckexecutor.o cli/filelister.o\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
- fout << "test:\tall\n";
- fout << "\t./testrunner\n\n";
- fout << "check:\tall\n";
diff --git a/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch
deleted file mode 100644
index 0ad79ebf4d0d..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-diff --git a/gui/gui.pro b/gui/gui.pro
-index 0cbaebf..cb381dd 100644
---- a/gui/gui.pro
-+++ b/gui/gui.pro
-@@ -15,6 +15,7 @@ contains(LINKCORE, [yY][eE][sS]) {
- DEFINES += CPPCHECKLIB_IMPORT
- }
- LIBS += -L$$PWD/../externals
-+LIBS += $(shell $(PKG_CONFIG) --libs tinyxml2)
-
- DESTDIR = .
- RCC_DIR = temp
-diff --git a/tools/dmake.cpp b/tools/dmake.cpp
-index 298cb98..c3afd26 100644
---- a/tools/dmake.cpp
-+++ b/tools/dmake.cpp
-@@ -122,7 +122,6 @@ int main(int argc, char **argv)
-
- std::vector<std::string> extfiles;
- extfiles.push_back("externals/simplecpp/simplecpp.cpp");
-- extfiles.push_back("externals/tinyxml/tinyxml2.cpp");
-
- std::vector<std::string> clifiles;
- getCppFiles(clifiles, "cli/", false);
-@@ -171,7 +170,6 @@ int main(int argc, char **argv)
- std::ofstream fout1("test/testfiles.pri");
- if (fout1.is_open()) {
- fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
-- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
- fout1 << "\n\nSOURCES += ";
- for (unsigned int i = 0; i < testfiles.size(); ++i) {
- const std::string filename(testfiles[i].substr(5));
-@@ -341,9 +339,9 @@ int main(int argc, char **argv)
- << "endif\n\n";
-
- makeConditionalVariable(fout, "PREFIX", "/usr");
-- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp -isystem externals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp -isystem externals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp -isystem externals/tinyxml");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp");
-
- fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
- fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
-diff --git a/oss-fuzz/Makefile b/oss-fuzz/Makefile
-index 81cf654..26f9da9 100644
---- a/oss-fuzz/Makefile
-+++ b/oss-fuzz/Makefile
-@@ -6,8 +6,8 @@
- # make CXX=clang++-6.0 CXXFLAGS="-fsanitize=address" fuzz-client
-
- CPPCHECK_DIR=..
--INCLUDE_DIR=-I ${CPPCHECK_DIR}/lib -I ${CPPCHECK_DIR}/externals/simplecpp -I ${CPPCHECK_DIR}/externals/tinyxml -I ${CPPCHECK_DIR}/externals
--SRC_FILES=main.cpp type2.cpp ${CPPCHECK_DIR}/externals/simplecpp/simplecpp.cpp ${CPPCHECK_DIR}/externals/tinyxml/tinyxml2.cpp ${CPPCHECK_DIR}/lib/*.cpp
-+INCLUDE_DIR=-I ${CPPCHECK_DIR}/lib -I ${CPPCHECK_DIR}/externals/simplecpp -I ${CPPCHECK_DIR}/externals
-+SRC_FILES=main.cpp type2.cpp ${CPPCHECK_DIR}/externals/simplecpp/simplecpp.cpp ${CPPCHECK_DIR}/lib/*.cpp
-
- all: oss-fuzz-client translate
-
-diff --git a/Makefile b/Makefile
-index 372647e..9d65717 100644
---- a/Makefile
-+++ b/Makefile
-@@ -179,8 +179,7 @@ LIBOBJ = $(libcppdir)/analyzerinfo.o \
- $(libcppdir)/tokenlist.o \
- $(libcppdir)/valueflow.o
-
--EXTOBJ = externals/simplecpp/simplecpp.o \
-- externals/tinyxml/tinyxml2.o
-+EXTOBJ = externals/simplecpp/simplecpp.o
-
- CLIOBJ = cli/cmdlineparser.o \
- cli/cppcheckexecutor.o \
-@@ -689,9 +688,6 @@ test/testvarid.o: test/testvarid.cpp lib/platform.h lib/config.h lib/settings.h
- externals/simplecpp/simplecpp.o: externals/simplecpp/simplecpp.cpp externals/simplecpp/simplecpp.h
- $(CXX) $(CPPFLAGS) $(CFG) $(CXXFLAGS) -w $(UNDEF_STRICT_ANSI) -c -o externals/simplecpp/simplecpp.o externals/simplecpp/simplecpp.cpp
-
--externals/tinyxml/tinyxml2.o: externals/tinyxml/tinyxml2.cpp externals/tinyxml/tinyxml2.h
-- $(CXX) $(CPPFLAGS) $(CFG) $(CXXFLAGS) -w $(UNDEF_STRICT_ANSI) -c -o externals/tinyxml/tinyxml2.o externals/tinyxml/tinyxml2.cpp
--
- tools/clang-ast.o: tools/clang-ast.cpp
- $(CXX) ${INCLUDE_FOR_LIB} $(CPPFLAGS) $(CFG) $(CXXFLAGS) $(UNDEF_STRICT_ANSI) -c -o tools/clang-ast.o tools/clang-ast.cpp
-
-diff --git a/externals/externals.pri b/externals/externals.pri
-index 7f0be8d..b1e94e0 100644
---- a/externals/externals.pri
-+++ b/externals/externals.pri
-@@ -1,9 +1,6 @@
- INCLUDEPATH += $${PWD} \
-- $${PWD}/simplecpp \
-- $${PWD}/tinyxml
-+ $${PWD}/simplecpp
-
--HEADERS += $${PWD}/simplecpp/simplecpp.h \
-- $${PWD}/tinyxml/tinyxml2.h
-+HEADERS += $${PWD}/simplecpp/simplecpp.h
-
--SOURCES += $${PWD}/simplecpp/simplecpp.cpp \
-- $${PWD}/tinyxml/tinyxml2.cpp
-+SOURCES += $${PWD}/simplecpp/simplecpp.cpp