summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index 0e4edd84d5a6..48ed33424220 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1,2 +1 @@
-DIST intel-graphics-system-controller-0.2.3.tar.gz 124505 BLAKE2B 50bfaf5dee2fd55d92cd7e544faa8c26930f809b1f4d6dbdc332aec0ace0ced9e21817479c87c4ec12d1117209696b2146c2c6aeb1cfde4ad654d065547e8a6b SHA512 a3ecac36170b0f5c508e077c35336f5c2122d4cc2917e68237af3c92fb82b5f080deee4dded68cb36922cb9edd4d78f7b7a6ed2295649a538ab83ad30c280761
DIST intel-graphics-system-controller-0.2.4.tar.gz 125476 BLAKE2B 82c803dc654240a364416dcca6c1104ec96eca6a0ffec058394ec2594d87bdd6854a3b0143ad6e114b5b4359b15f787679c995fa60fcbbcf5097467c15252217 SHA512 57b0aa1f5cfb6c103903be590d94f4a07c33c90180e688b62b2434baddf16637a6fb6c160c225fa08cf2d0efc80a42c6b86de48b71fb6aa08bd3f9fe2ff79fa6
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
deleted file mode 100644
index f38cef881cca..000000000000
--- a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.2.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="igsc"
-MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Intel graphics system controller firmware update library"
-HOMEPAGE="https://github.com/intel/igsc"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+cli doc"
-
-RDEPEND="dev-libs/metee"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- app-doc/doxygen
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- )
-"
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_CLI="$(usex cli)"
- -DENABLE_DOCS="$(usex doc)"
- -DENABLE_ENUM="ON"
- -DENABLE_PERF="OFF"
- -DENABLE_WERROR="OFF"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DENABLE_TESTS="OFF"
- )
-
- cmake_src_configure
-}