summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/radare2/Manifest4
-rw-r--r--dev-util/radare2/radare2-2.1.0-r1.ebuild63
-rw-r--r--dev-util/radare2/radare2-2.1.0-r2.ebuild56
-rw-r--r--dev-util/radare2/radare2-2.1.0.ebuild59
-rw-r--r--dev-util/radare2/radare2-2.2.0.ebuild56
-rw-r--r--dev-util/radare2/radare2-2.3.0.ebuild56
-rw-r--r--dev-util/radare2/radare2-2.4.0.ebuild56
7 files changed, 0 insertions, 350 deletions
diff --git a/dev-util/radare2/Manifest b/dev-util/radare2/Manifest
index 0994fcab3d49..6e6a1d55e9b3 100644
--- a/dev-util/radare2/Manifest
+++ b/dev-util/radare2/Manifest
@@ -1,5 +1 @@
-DIST radare2-2.1.0.tar.gz 5954222 BLAKE2B 9128a01d40ef1401d457f1fa5610ad7bbda92021e6e16fd70e9488bdb11be923c3d0f453e49a7bf78203c320ec2f1b2276925db2ae6eeaad90100ae0c2724b56 SHA512 38a907834e21967a83943e62cb29d8097e0522ff71ea61a2e3ab9e5263c3884ce28c17fb3ca9201c2b9f341e1b066ed0899e5152e146e61fc4f650f319299cd0
-DIST radare2-2.2.0.tar.gz 6145228 BLAKE2B e85d2243b477f5e233d4cb1989452f3bce798e356b8022eaa7b90ca6027ee01365868c6b933a3c3470ef0d80e107d955d4127e55ee7664e829b44259facd1863 SHA512 e632ca3ffdeefc394e571b5ae7f0619cbbb93c657ff1ef316771e1d10089fbad98dc08b6e7d152e664a4c16e97d4519c1c6445fe737dbd4e3d296bc93c3ee410
-DIST radare2-2.3.0.tar.gz 6175929 BLAKE2B ac52ce32d4161b51adcc988a4adb02d02cef2e05bf90325f032585973874cdaa370f00a5f7734e7c00787beaf579c1745de27271c35f63f54d31003f6328c95a SHA512 4b52ae3678c5bbba1d173f95715807469e88603067faf4f1058606a4235050ec07aebdb6408e24c0c031b9554b4ca095bf77fc2791a9efa498dfff49200b3b1d
-DIST radare2-2.4.0.tar.gz 6301920 BLAKE2B 8a1b6322d293e16d743bc49f799bc90754a648b0c257f126ea3c652ced46773dd1124f618bd5cf4db91acd324a43581218b70cb821004e3d551778cfb7f6bc6d SHA512 fca5f78c7e1dab4af0aa4bf367953bc7a49bbd9da3ab7b32e8be79cc3c4f6a1be0db4c466d5f6e68c87c569d0096dd2841ea52f4ad75234046f1a96d8b4d4fc3
DIST radare2-2.5.0.tar.gz 6272646 BLAKE2B 44c88327b544d03bd464f1ecb72a51b7e3fa86602aeae9055b6f2d41763be9ed9d63be4c7b959e1f920605feeed998c1f56ef0ed3a6a7213b4d5265c057b1213 SHA512 a29e0e61aeee6e08a99a1ed8a8bc428ec8b0474b3781475db3091232353d03d39d8750f774a266e01bb7565049269ee5f43b666b3b69bfadafb75cdb35f6cc4b
diff --git a/dev-util/radare2/radare2-2.1.0-r1.ebuild b/dev-util/radare2/radare2-2.1.0-r1.ebuild
deleted file mode 100644
index f9184e637759..000000000000
--- a/dev-util/radare2/radare2-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils bash-completion-r1
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.9-nogit.patch
-)
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone zsh-completion bash-completion"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
- fi
-
- if use bash-completion; then
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- fi
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-2.1.0-r2.ebuild b/dev-util/radare2/radare2-2.1.0-r2.ebuild
deleted file mode 100644
index 2cf3090aec73..000000000000
--- a/dev-util/radare2/radare2-2.1.0-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils bash-completion-r1
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-2.1.0.ebuild b/dev-util/radare2/radare2-2.1.0.ebuild
deleted file mode 100644
index 13f59936254d..000000000000
--- a/dev-util/radare2/radare2-2.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.9.9-nogit.patch
-)
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone zsh-completion"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
- fi
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-2.2.0.ebuild b/dev-util/radare2/radare2-2.2.0.ebuild
deleted file mode 100644
index 2cf3090aec73..000000000000
--- a/dev-util/radare2/radare2-2.2.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils bash-completion-r1
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-2.3.0.ebuild b/dev-util/radare2/radare2-2.3.0.ebuild
deleted file mode 100644
index 2cf3090aec73..000000000000
--- a/dev-util/radare2/radare2-2.3.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils bash-completion-r1
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}
diff --git a/dev-util/radare2/radare2-2.4.0.ebuild b/dev-util/radare2/radare2-2.4.0.ebuild
deleted file mode 100644
index abe520e9a37a..000000000000
--- a/dev-util/radare2/radare2-2.4.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils bash-completion-r1
-
-DESCRIPTION="unix-like reverse engineering framework and commandline tools"
-HOMEPAGE="http://www.radare.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/radare/radare2"
-else
- SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~arm ~arm64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ssl libressl +system-capstone"
-
-RDEPEND="
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- system-capstone? ( dev-libs/capstone:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_configure() {
- econf \
- $(use_with ssl openssl) \
- $(use_with system-capstone syscapstone)
-}
-
-src_install() {
- default
-
- insinto /usr/share/zsh/site-functions
- doins doc/zsh/_*
-
- newbashcomp doc/bash_autocompletion.sh "${PN}"
- bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
-
- # a workaround for unstable $(INSTALL) call, bug #574866
- local d
- for d in doc/*; do
- if [[ -d $d ]]; then
- rm -rfv "$d" || die "failed to delete '$d'"
- fi
- done
-}