summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lcov/Manifest2
-rw-r--r--dev-util/lcov/lcov-1.15.ebuild43
-rw-r--r--dev-util/lcov/lcov-1.16-r1.ebuild52
-rw-r--r--dev-util/lcov/lcov-2.0-r1.ebuild85
4 files changed, 0 insertions, 182 deletions
diff --git a/dev-util/lcov/Manifest b/dev-util/lcov/Manifest
index 211e7170c298..1c6be2a9078c 100644
--- a/dev-util/lcov/Manifest
+++ b/dev-util/lcov/Manifest
@@ -1,3 +1 @@
-DIST lcov-1.15.tar.gz 190487 BLAKE2B 2d6478caae488b84c74a3f7b489013b065b3e8fb106a6e8c5f413ffe87be7f4530aade8d2b5df5b8193949d60f49d5255b4eddb0cd5f1cab6f450ba2f97426ab SHA512 dda0eadbd0ea2093f17cba039309ccda3dbcb7266d083b46bda61e02cd7f049d66de49be1e005157c3e5af910d2703ffbc9cfe7f1242bd67b9787f8508e4d052
-DIST lcov-1.16.tar.gz 196813 BLAKE2B 2a0a2d3ff6291eb3e9cc290006a3723451ab276891f9b63f8dcce82a305caa5558b5bb7bc72fa11620130824df4f9c4312edc23eb86f98eab4a8879e1212a3d5 SHA512 f9fdc5348a97e4262a22d1594df7847165c93447fd5d264d194029f86bf751f18bf91badaf0172d406bca98e4bb3997f133a3ca144105f5acfabeec82f369a37
DIST lcov-2.0.tar.gz 391695 BLAKE2B 737d6104ebedf90ba2c3bf0c439dd7e2d18724d7267c3bd79897140785246d9ed6334eec9eabc888e361f5e22515da9756e946e1097777fb88c140398b0b078a SHA512 b19b6debc93c0de0e7e5b2aaffa6c74d20a1313ea4d20d8731c6a5ea7f4cc40933316d28ef791c91fdc12ca77c9449a388405f3dc0793588e366b72f596ab49b
diff --git a/dev-util/lcov/lcov-1.15.ebuild b/dev-util/lcov/lcov-1.15.ebuild
deleted file mode 100644
index 3406992d454b..000000000000
--- a/dev-util/lcov/lcov-1.15.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
-fi
-
-inherit optfeature prefix
-
-DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-RDEPEND="
- dev-lang/perl
- dev-perl/JSON
- dev-perl/PerlIO-gzip
-"
-
-src_prepare() {
- default
- if use prefix; then
- hprefixify bin/*.{pl,sh}
- fi
-}
-
-src_compile() { :; }
-
-src_install() {
- emake -j1 PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
-}
-
-pkg_postinst() {
- optfeature "png output support" dev-perl/GD[png]
-}
diff --git a/dev-util/lcov/lcov-1.16-r1.ebuild b/dev-util/lcov/lcov-1.16-r1.ebuild
deleted file mode 100644
index 11ab700358b7..000000000000
--- a/dev-util/lcov/lcov-1.16-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
-fi
-
-inherit optfeature prefix
-
-DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="https://github.com/linux-test-project/lcov"
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-RDEPEND="
- dev-lang/perl
- dev-perl/JSON
- dev-perl/PerlIO-gzip
-"
-
-src_prepare() {
- default
- if use prefix; then
- hprefixify bin/*.{pl,sh}
- fi
-}
-
-src_compile() { :; }
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- emake -j1 \
- DESTDIR="${D}" \
- CFG_DIR="${EPREFIX}/etc" \
- PREFIX="${EPREFIX}/usr" \
- LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
- install
-}
-
-pkg_postinst() {
- optfeature "png output support" dev-perl/GD[png]
-}
diff --git a/dev-util/lcov/lcov-2.0-r1.ebuild b/dev-util/lcov/lcov-2.0-r1.ebuild
deleted file mode 100644
index 5f3d996311f4..000000000000
--- a/dev-util/lcov/lcov-2.0-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit optfeature prefix python-any-r1
-
-DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
-HOMEPAGE="https://github.com/linux-test-project/lcov"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Python is used for spreadsheet.py
-RDEPEND="
- dev-lang/perl
- dev-perl/Capture-Tiny
- dev-perl/DateTime
- || (
- dev-perl/JSON-XS
- dev-perl/Cpanel-JSON-XS
- virtual/perl-JSON-PP
- dev-perl/JSON
- )
- dev-perl/PerlIO-gzip
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-perl/GD
- $(python_gen_any_dep '
- dev-python/xlsxwriter[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- python_has_version "dev-python/xlsxwriter[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
- if use prefix; then
- hprefixify bin/*.{pl,sh}
- fi
-}
-
-src_compile() { :; }
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- emake -j1 \
- DESTDIR="${D}" \
- CFG_DIR="${EPREFIX}/etc" \
- PREFIX="${EPREFIX}/usr" \
- LCOV_PERL_PATH="${EPREFIX}/usr/bin/perl" \
- install
-}
-
-pkg_postinst() {
- optfeature_header "Optional outuput support:"
- optfeature "png output support" dev-perl/GD[png]
- optfeature "spreadsheet output support" dev-python/xlsxwriter
- optfeature_header "Optional language support:"
- optfeature "Python code coverage support" dev-python/coverage
- optfeature "Perl code coverage support" dev-perl/Devel-Cover
-}