summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/netbeans/Manifest3
-rw-r--r--dev-util/netbeans/netbeans-8.1.ebuild253
2 files changed, 256 insertions, 0 deletions
diff --git a/dev-util/netbeans/Manifest b/dev-util/netbeans/Manifest
index a8b3cdda8e74..576db7765a8f 100644
--- a/dev-util/netbeans/Manifest
+++ b/dev-util/netbeans/Manifest
@@ -1,3 +1,6 @@
DIST netbeans-8.0.2-201411181905-src.zip 196585461 SHA256 581f80d3c2e8d87a0f007dd3f358ce0534a0bb2e4b3312cd6c8c7263713bc530 SHA512 9533de5b3c45e4a5b025213dd5602344e16d024e0cdb013f207ac3c7a9d8e63da19279f97910ad136777d75780c620224953f2974070d5c9833d1d6ef3fd427c WHIRLPOOL 2e45e83309743df167ddd1d58068848166d01ef6d9eec99ddf72b9ba7664cb182a04d6420ab03a9270842b3cd9a16a161c1eebb66953ef09158d8d521fb96516
DIST netbeans-8.0.2-build.xml.patch.bz2 2678 SHA256 cf120f7fd8b4ad40e9abdcb09e7763fd93b4acef04ff0365e18f178706ea83bb SHA512 b61adf29bcb139207241c68513724f352420078583ca5e6d7856a4dd335ad36b7d05311eb6e14ff1c568aaf090de4ca083c32f6db1dec0b6f50d66a388bbedf7 WHIRLPOOL fb4d63329aa450a1b387fa45b59fa3c18d1a1ca8ecf9443111a3056d409a6d928d15dae275e9c564558f4b2abd54cc0f8db2df653ac432d9f58f8ef4dd747dff
+DIST netbeans-8.1-201510222201-src.zip 208692973 SHA256 e8dd9b73304bc7e546150629f7555624b405e8a7af2cd5d616e7a91a0655f463 SHA512 c3ed9e8c9444b1685e3ed7e1a2525d8be43953994aebed962d39f8eae35b6ab0dcab0093b7eeb287e3c74e0620ceded1956ef93205837bb7749db49f53c1c285 WHIRLPOOL 7ff7c3441dbc8f1ebd6f5441c8371ef0ef392f45eef65e06efec3201f417e228fb32879df83ec23ae61898840eadcde43caa66d54182bf3aae2f44c683916268
+DIST netbeans-8.1-build.xml.patch.bz2 2671 SHA256 b5384db6533d41c7d3fdaffd3cd296d156ac99f0a026e3d74c4ac5b5d388a70f SHA512 1dd5dcf02fd81691b0f9c531470379138484dcbc271f65ba53a3844a1e697719e47cb98c90f92f92c5980a577d27370efc800297525f62da7211393ea0a18915 WHIRLPOOL c77621b5f4eea9e688d9714be9268d05f7c1e792d9d46d3a082418d8c1cb52c35f76d59f0befddc73f30a0e0e12c0af25b4b31c1cb69b68dd90e48638d7da509
DIST netbeans-l10n-8.0.1-20141110.tar.bz2 12065358 SHA256 542d325cbc6e0e617f6076e964e37803ec322b6d0ee4724a6d2127f2f480fb24 SHA512 28242dcbe7bcbc6a9abce15dfe6fd6140a275a417d96ff28228315bdc0ce8110ede899a1815e2fdf9115b48221d50cd3ff5b71a15d36316d04d81f66e9c0cac4 WHIRLPOOL 0318caea3463d3f7bb8876774b1cc9467dadd9bc36497a9304ed12900e2fabdc4dcdfec0b9eaee27bb36c39e9caff3743c5a42ad4c3a432205a716832688c4d6
+DIST netbeans-l10n-8.1-20151105.tar.bz2 11945028 SHA256 33e86aa7315021d28fdb64790233327d7599c98bcf3ab9d936b6fe924884325a SHA512 eb3163eaa8add417a0e8ac3ed4923a6e4992a80eaac00a01eed24e0e1ceb8a5cbd308659bcf0e5e1192ac8e84a79ea36744ad6b2589d60891b03b37102e9435d WHIRLPOOL f214a865bfd8c54341fb9d538da6db4d9b24906b0d94b3ee6cbf4a525e8842d28e852febb2f34c4c31f989d1b6baf750480bc2f04d94bcd7a8bdb8c9553ef590
diff --git a/dev-util/netbeans/netbeans-8.1.ebuild b/dev-util/netbeans/netbeans-8.1.ebuild
new file mode 100644
index 000000000000..396b5dec3377
--- /dev/null
+++ b/dev-util/netbeans/netbeans-8.1.ebuild
@@ -0,0 +1,253 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans IDE"
+HOMEPAGE="http://netbeans.org/"
+SLOT="8.1"
+SOURCE_URL="http://download.netbeans.org/netbeans/8.1/final/zip/netbeans-8.1-201510222201-src.zip"
+PATCHES_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.1-build.xml.patch.bz2"
+L10N_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-l10n-8.1-20151105.tar.bz2"
+ALL_URLS="${SOURCE_URL} ${PATCHES_URL} ${L10N_URL}"
+SRC_URI="linguas_af? ( ${ALL_URLS} )
+ linguas_ar? ( ${ALL_URLS} )
+ linguas_ar_SA? ( ${ALL_URLS} )
+ linguas_bg? ( ${ALL_URLS} )
+ linguas_ca? ( ${ALL_URLS} )
+ linguas_cs? ( ${ALL_URLS} )
+ linguas_de? ( ${ALL_URLS} )
+ linguas_el? ( ${ALL_URLS} )
+ linguas_es? ( ${ALL_URLS} )
+ linguas_es_CO? ( ${ALL_URLS} )
+ linguas_fil? ( ${ALL_URLS} )
+ linguas_fr? ( ${ALL_URLS} )
+ linguas_gl? ( ${ALL_URLS} )
+ linguas_hi_IN? ( ${ALL_URLS} )
+ linguas_id_ID? ( ${ALL_URLS} )
+ linguas_it? ( ${ALL_URLS} )
+ linguas_ja? ( ${ALL_URLS} )
+ linguas_ko? ( ${ALL_URLS} )
+ linguas_lt? ( ${ALL_URLS} )
+ linguas_nl_BE? ( ${ALL_URLS} )
+ linguas_nl_NL? ( ${ALL_URLS} )
+ linguas_pl? ( ${ALL_URLS} )
+ linguas_pt_BR? ( ${ALL_URLS} )
+ linguas_pt_PT? ( ${ALL_URLS} )
+ linguas_ro? ( ${ALL_URLS} )
+ linguas_ru? ( ${ALL_URLS} )
+ linguas_si? ( ${ALL_URLS} )
+ linguas_sq? ( ${ALL_URLS} )
+ linguas_sr? ( ${ALL_URLS} )
+ linguas_sv? ( ${ALL_URLS} )
+ linguas_ta_IN? ( ${ALL_URLS} )
+ linguas_tr? ( ${ALL_URLS} )
+ linguas_vi? ( ${ALL_URLS} )
+ linguas_zh_CN? ( ${ALL_URLS} )
+ linguas_zh_TW? ( ${ALL_URLS} )
+"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE_NETBEANS_MODULES="
+ +netbeans_modules_apisupport
+ netbeans_modules_cnd
+ netbeans_modules_dlight
+ netbeans_modules_enterprise
+ netbeans_modules_ergonomics
+ netbeans_modules_extide
+ netbeans_modules_groovy
+ +netbeans_modules_java
+ netbeans_modules_javacard
+ +netbeans_modules_javafx
+ netbeans_modules_mobility
+ netbeans_modules_php
+ +netbeans_modules_profiler
+ netbeans_modules_webcommon
+ +netbeans_modules_websvccommon"
+IUSE_LINGUAS="
+ linguas_af
+ linguas_ar
+ linguas_ar_SA
+ linguas_bg
+ linguas_ca
+ linguas_cs
+ linguas_de
+ linguas_el
+ linguas_es
+ linguas_es_CO
+ linguas_fil
+ linguas_fr
+ linguas_gl
+ linguas_hi_IN
+ linguas_id_ID
+ linguas_it
+ linguas_ja
+ linguas_ko
+ linguas_lt
+ linguas_nl_BE
+ linguas_nl_NL
+ linguas_pl
+ linguas_pt_BR
+ linguas_pt_PT
+ linguas_ro
+ linguas_ru
+ linguas_si
+ linguas_sq
+ linguas_sr
+ linguas_sv
+ linguas_ta_IN
+ linguas_tr
+ linguas_vi
+ linguas_zh_CN
+ linguas_zh_TW"
+IUSE="doc ${IUSE_NETBEANS_MODULES} ${IUSE_LINGUAS}"
+S="${WORKDIR}"
+
+DEPEND=">=virtual/jdk-1.7
+ dev-java/javahelp:0"
+RDEPEND=">=virtual/jdk-1.7
+ ~dev-java/netbeans-harness-${PV}
+ ~dev-java/netbeans-ide-${PV}
+ ~dev-java/netbeans-nb-${PV}
+ ~dev-java/netbeans-platform-${PV}
+ netbeans_modules_apisupport? ( ~dev-java/netbeans-apisupport-${PV} )
+ netbeans_modules_cnd? ( ~dev-java/netbeans-cnd-${PV} )
+ netbeans_modules_dlight? ( ~dev-java/netbeans-dlight-${PV} )
+ netbeans_modules_enterprise? ( ~dev-java/netbeans-enterprise-${PV} )
+ netbeans_modules_ergonomics? ( ~dev-java/netbeans-ergonomics-${PV} )
+ netbeans_modules_extide? ( ~dev-java/netbeans-extide-${PV} )
+ netbeans_modules_groovy? ( ~dev-java/netbeans-groovy-${PV} )
+ netbeans_modules_java? ( ~dev-java/netbeans-java-${PV} )
+ netbeans_modules_javacard? ( ~dev-java/netbeans-javacard-${PV} )
+ netbeans_modules_javafx? ( ~dev-java/netbeans-javafx-${PV} )
+ netbeans_modules_mobility? ( ~dev-java/netbeans-mobility-${PV} )
+ netbeans_modules_php? ( ~dev-java/netbeans-php-${PV} )
+ netbeans_modules_profiler? ( ~dev-java/netbeans-profiler-${PV} )
+ netbeans_modules_webcommon? ( ~dev-java/netbeans-webcommon-${PV} )
+ netbeans_modules_websvccommon? ( ~dev-java/netbeans-websvccommon-${PV} )
+ doc? ( ~dev-java/netbeans-javadoc-${PV} )"
+JAVA_PKG_BSFIX="off"
+NBLOCALES=""
+
+pkg_setup() {
+ for lingua in ${IUSE_LINGUAS} ; do
+ local lang=${lingua/linguas_/}
+
+ if [[ "${lang}" = "ar" ]] ; then
+ lang="ar_EG,ar_SA"
+ elif [[ "${lang}" = "es" ]] ; then
+ lang="es,es_CO"
+ elif [[ "${lang}" = "fil" ]] ; then
+ lang="fil_PH"
+ elif [[ "${lang}" = "gl" ]] ; then
+ lang="gl_ES"
+ elif [[ "${lang}" = "id_ID" ]] ; then
+ lang="in_ID"
+ fi
+
+ if use ${lingua} ; then
+ if [ -z "${NBLOCALES}" ] ; then
+ NBLOCALES="${lang}"
+ else
+ NBLOCALES="${NBLOCALES},${lang}"
+ fi
+ fi
+ done
+
+ java-pkg-2_pkg_setup
+}
+
+src_unpack() {
+ if [ -n "${NBLOCALES}" ] ; then
+ unpack $(basename ${SOURCE_URL})
+ unpack $(basename ${L10N_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-8.1-build.xml.patch.bz2
+ fi
+}
+
+src_prepare() {
+ if [ -n "${NBLOCALES}" ] ; then
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-8.1-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+ fi
+
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ if [ -n "${NBLOCALES}" ] ; then
+ einfo "Compiling support for locales: ${NBLOCALES}"
+ eant -f nbbuild/build.xml bootstrap || die
+ eant -Dlocales=${NBLOCALES} -Ddist.dir=../nbbuild/netbeans -Dnbms.dir="" -Dnbms.dist.dir="" \
+ -Dpermit.jdk7.builds=true -f l10n/build.xml build || die
+ fi
+}
+
+src_install() {
+ if [ -n "${NBLOCALES}" ] ; then
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ for cluster in apisupport cnd dlight enterprise ergonomics groovy harness ide java javacard javafx mobility php platform profiler webcommon websvccommon ; do
+ if [ -d "${cluster}" ] ; then
+ insinto /usr/share/netbeans-${cluster}-${SLOT}
+ doins -r ${cluster}/*
+ fi
+ done
+
+ if [ -d nb ] ; then
+ insinto /usr/share/netbeans-nb-${SLOT}/nb
+ doins -r nb/*
+ fi
+
+ popd >/dev/null || die
+ fi
+}
+
+pkg_postinst() {
+ if [ -n "${NBLOCALES}" ] ; then
+ einfo "Netbeans automatically starts with the locale you have set in your user profile, if"
+ einfo "the locale is built for Netbeans."
+ einfo "If you want to force specific locale, use --locale argument, for example:"
+ einfo "${PN}-${SLOT} --locale de"
+ einfo "${PN}-${SLOT} --locale pt:BR"
+ fi
+
+ if use linguas_ar ; then
+ einfo
+ einfo "You selected Arabic locale so you can choose either ar:EG or ar:SA variant."
+ fi
+
+ if use linguas_es ; then
+ einfo
+ einfo "You selected Spanish locale so you can choose either es or es:CO variant."
+ fi
+
+ if use linguas_id_ID ; then
+ einfo
+ einfo "You selected Indonesian locale which has locale code in:ID in Netbeans."
+ fi
+}