summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.46.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
index 2e7380ae9e4c..9ee31dc20110 100644
--- a/dev-util/sysprof-capture/Manifest
+++ b/dev-util/sysprof-capture/Manifest
@@ -1,2 +1,3 @@
DIST sysprof-3.36.0.tar.xz 435956 BLAKE2B 990a6c6c28339594df915ed1fb98f504bf6b080a5e3c31af0cc4bcfd208027361f02a9068291692d082787a6fd42ab414079122a63e4706aee2511040379f0c8 SHA512 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
DIST sysprof-3.44.0.tar.xz 493924 BLAKE2B c3d9558df99ba23f63fbde0df54e201afce83da8f7d64166b44fcc2c70ec9e54a4abfbd0ac64171b1538af7e9d608b0f618559aba9444a3d884cd4944c4d595f SHA512 64bfe4d39e71954f7982ef06caffc39ff60d2d6005f8392a7918f83263d7c5b11bafdf7234ed86d52063586919a4dbe742c498b6f1f9db91d481337cf568451c
+DIST sysprof-3.46.0.tar.xz 518536 BLAKE2B 8925f0cbe34411cce6bd86e9f4a924d3ff627429812682898fffe0a08c2dab9228e5d8bde44b460404f90fb29961a30154af1e8240df24bfa20b70cc7a36448e SHA512 ac248e2a06d2f7905bebae4e685dd320e3ac85097e33b9c6b8482a4647a5bfcaadc4d9a1fe117b3a74cb855d6c72d9a1453a37d7b64762a223c0fe5da2653a87
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.46.0.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.46.0.ebuild
new file mode 100644
index 000000000000..b3a112c3c6fb
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.46.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson-multilib systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgtk=false
+ -Dlibsysprof=false
+ -Dinstall-static=true
+ -Dsysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ -Dlibunwind=false
+ -Dtools=false
+ -Dtests=false
+ -Dexamples=false
+ -Dagent=false
+ )
+ meson_src_configure
+}